Source Filmmaker > Genel Başlıklar > Konu Detayları
Squid 28 Eki 2012 @ 4:16pm
SFM Hammer won't start
Is there a reason why it won't start? Can I fix it? Help!
12 yorumdan 1 ile 12 arası gösteriliyor
< >
PalmliX 28 Eki 2012 @ 4:43pm 
What happens exactly when you try and run it?
Squid 28 Eki 2012 @ 4:48pm 
I click on hammer.exe in the SFM bin folder, and it won't start up.
PalmliX 28 Eki 2012 @ 4:59pm 
you mean nothing happens? no error or anything?
Squid 28 Eki 2012 @ 5:02pm 
Nothing happens. No errors, nothing.
PalmliX 28 Eki 2012 @ 5:13pm 
Try running it as administrator, try running it in xp compatibility mode, install the Source SDK's and make sure the game is set to the Orange Box (not sure if this does anything but it can't hurt) or if it's already installed try resetting the configuration: https://developer.valvesoftware.com/wiki/Reset_the_Source_SDK_Game_Configuration

Also check this: https://developer.valvesoftware.com/wiki/The_Game_Directory
nailbiter 28 Eki 2012 @ 5:20pm 
running into same problem.. can't even launch the SFM SDK or Hammer.exe. SFM runs fine though.
PC's_Frank 29 Eki 2012 @ 5:23pm 
Hammer's been doing all kinds of weird things all weekend. I think it has to do with the TF2 update.
[NIИ]Complication 4 Kas 2012 @ 1:55am 
does anyone have any solution to this?
En son [NIИ]Complication tarafından düzenlendi; 4 Kas 2012 @ 1:55am
[NIИ]Complication 4 Kas 2012 @ 3:37am 
I FOUND THE SOLUTION.

Somehow somewhere GameConfig.txt has been deleted after update.

You have to put this file in SFM bin directory where hammer sits

"Configs"
{
"Games"
{
"usermod"
{
"GameDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod"
"Hammer"
{
"GameData0" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\tf.fgd"
"TextureFormat" "5"
"MapFormat" "4"
"DefaultTextureScale" "0.250000"
"DefaultLightmapScale" "16"
"GameExe" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\sfm.exe"
"DefaultSolidEntity" "func_detail"
"DefaultPointEntity" "info_player_teamspawn"
"BSP" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vbsp.exe"
"Vis" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vvis.exe"
"Light" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vrad.exe"
"GameExeDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game"
"MapDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\content\usermod\mapsrc"
"BSPDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod\maps"
"PrefabDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\Prefabs"
"CordonTexture" "tools\toolsskybox"
MaterialExcludeCount" "0"
}
}
}
"SDKVersion" "5"
}

Obviously you have to replace "YOUR STEAM FOLDER" with full path, including drive, where your steam is installed, for example C:\Program Files\Steam\etc etc
Squid 4 Kas 2012 @ 8:55am 
I did the above solution and it still won't launch.
SeTh 16 Haz 2013 @ 3:14am 
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?
raptornx01 16 Haz 2013 @ 4:25am 
<SaVaGe> INSANE^Aka tarafından gönderilen ileti:
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?

where are you launching from?
12 yorumdan 1 ile 12 arası gösteriliyor
< >
Sayfa başına: 15 30 50
Gönderilme Tarihi: 28 Eki 2012 @ 4:16pm
İleti: 12