Source Filmmaker > 一般的な話題 > トピックの詳細
The Seemingly Innocuous Squid 2012年10月28日 16時16分
SFM Hammer won't start
Is there a reason why it won't start? Can I fix it? Help!
1-12 / 12 のコメントを表示
< >
PalmliX 2012年10月28日 16時43分 
What happens exactly when you try and run it?
The Seemingly Innocuous Squid 2012年10月28日 16時48分 
I click on hammer.exe in the SFM bin folder, and it won't start up.
PalmliX 2012年10月28日 16時59分 
you mean nothing happens? no error or anything?
The Seemingly Innocuous Squid 2012年10月28日 17時02分 
Nothing happens. No errors, nothing.
PalmliX 2012年10月28日 17時13分 
Try running it as administrator, try running it in xp compatibility mode, install the Source SDK's and make sure the game is set to the Orange Box (not sure if this does anything but it can't hurt) or if it's already installed try resetting the configuration: https://developer.valvesoftware.com/wiki/Reset_the_Source_SDK_Game_Configuration

Also check this: https://developer.valvesoftware.com/wiki/The_Game_Directory
nailbiter 2012年10月28日 17時20分 
running into same problem.. can't even launch the SFM SDK or Hammer.exe. SFM runs fine though.
PC's_Frank 2012年10月29日 17時23分 
Hammer's been doing all kinds of weird things all weekend. I think it has to do with the TF2 update.
[NIИ]Complication 2012年11月4日 1時55分 
does anyone have any solution to this?
最近の変更は[NIИ]Complicationが行いました; 2012年11月4日 1時55分
[NIИ]Complication 2012年11月4日 3時37分 
I FOUND THE SOLUTION.

Somehow somewhere GameConfig.txt has been deleted after update.

You have to put this file in SFM bin directory where hammer sits

"Configs"
{
"Games"
{
"usermod"
{
"GameDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod"
"Hammer"
{
"GameData0" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\tf.fgd"
"TextureFormat" "5"
"MapFormat" "4"
"DefaultTextureScale" "0.250000"
"DefaultLightmapScale" "16"
"GameExe" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\sfm.exe"
"DefaultSolidEntity" "func_detail"
"DefaultPointEntity" "info_player_teamspawn"
"BSP" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vbsp.exe"
"Vis" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vvis.exe"
"Light" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vrad.exe"
"GameExeDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game"
"MapDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\content\usermod\mapsrc"
"BSPDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod\maps"
"PrefabDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\Prefabs"
"CordonTexture" "tools\toolsskybox"
MaterialExcludeCount" "0"
}
}
}
"SDKVersion" "5"
}

Obviously you have to replace "YOUR STEAM FOLDER" with full path, including drive, where your steam is installed, for example C:\Program Files\Steam\etc etc
The Seemingly Innocuous Squid 2012年11月4日 8時55分 
I did the above solution and it still won't launch.
SeTh 2013年6月16日 3時14分 
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?
raptornx01 2013年6月16日 4時25分 
<SaVaGe> INSANE^Aka の投稿を引用:
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?

where are you launching from?
1-12 / 12 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年10月28日 16時16分
投稿数: 12