Source Filmmaker > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Squid (The Interloper) 28 Οκτ, 2012 @ 4:16μμ
SFM Hammer won't start
Is there a reason why it won't start? Can I fix it? Help!
Εμφάνιση 1-12 από 12 σχόλια
< >
PalmliX 28 Οκτ, 2012 @ 4:43μμ 
What happens exactly when you try and run it?
Squid (The Interloper) 28 Οκτ, 2012 @ 4:48μμ 
I click on hammer.exe in the SFM bin folder, and it won't start up.
PalmliX 28 Οκτ, 2012 @ 4:59μμ 
you mean nothing happens? no error or anything?
Squid (The Interloper) 28 Οκτ, 2012 @ 5:02μμ 
Nothing happens. No errors, nothing.
PalmliX 28 Οκτ, 2012 @ 5:13μμ 
Try running it as administrator, try running it in xp compatibility mode, install the Source SDK's and make sure the game is set to the Orange Box (not sure if this does anything but it can't hurt) or if it's already installed try resetting the configuration: https://developer.valvesoftware.com/wiki/Reset_the_Source_SDK_Game_Configuration

Also check this: https://developer.valvesoftware.com/wiki/The_Game_Directory
nailbiter 28 Οκτ, 2012 @ 5:20μμ 
running into same problem.. can't even launch the SFM SDK or Hammer.exe. SFM runs fine though.
PC's_Frank 29 Οκτ, 2012 @ 5:23μμ 
Hammer's been doing all kinds of weird things all weekend. I think it has to do with the TF2 update.
[NIИ]Complication 4 Νοε, 2012 @ 1:55πμ 
does anyone have any solution to this?
Τελευταία επεξεργασία από [NIИ]Complication; 4 Νοε, 2012 @ 1:55πμ
[NIИ]Complication 4 Νοε, 2012 @ 3:37πμ 
I FOUND THE SOLUTION.

Somehow somewhere GameConfig.txt has been deleted after update.

You have to put this file in SFM bin directory where hammer sits

"Configs"
{
"Games"
{
"usermod"
{
"GameDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod"
"Hammer"
{
"GameData0" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\tf.fgd"
"TextureFormat" "5"
"MapFormat" "4"
"DefaultTextureScale" "0.250000"
"DefaultLightmapScale" "16"
"GameExe" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\sfm.exe"
"DefaultSolidEntity" "func_detail"
"DefaultPointEntity" "info_player_teamspawn"
"BSP" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vbsp.exe"
"Vis" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vvis.exe"
"Light" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vrad.exe"
"GameExeDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game"
"MapDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\content\usermod\mapsrc"
"BSPDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod\maps"
"PrefabDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\Prefabs"
"CordonTexture" "tools\toolsskybox"
MaterialExcludeCount" "0"
}
}
}
"SDKVersion" "5"
}

Obviously you have to replace "YOUR STEAM FOLDER" with full path, including drive, where your steam is installed, for example C:\Program Files\Steam\etc etc
Squid (The Interloper) 4 Νοε, 2012 @ 8:55πμ 
I did the above solution and it still won't launch.
INϟANE★Aka♠ 16 Ιουν, 2013 @ 3:14πμ 
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?
raptornx01 16 Ιουν, 2013 @ 4:25πμ 
Αναρτήθηκε αρχικά από <SaVaGe> INSANE^Aka:
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?

where are you launching from?
Εμφάνιση 1-12 από 12 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 28 Οκτ, 2012 @ 4:16μμ
Αναρτήσεις: 12