Squid (Asshat) 28. Okt. 2012 um 16:16 Uhr
SFM Hammer won't start
Is there a reason why it won't start? Can I fix it? Help!
Beiträge 1-12 von 12
< >
PalmliX 28. Okt. 2012 um 16:43 Uhr 
What happens exactly when you try and run it?
Squid (Asshat) 28. Okt. 2012 um 16:48 Uhr 
I click on hammer.exe in the SFM bin folder, and it won't start up.
PalmliX 28. Okt. 2012 um 16:59 Uhr 
you mean nothing happens? no error or anything?
Squid (Asshat) 28. Okt. 2012 um 17:02 Uhr 
Nothing happens. No errors, nothing.
PalmliX 28. Okt. 2012 um 17:13 Uhr 
Try running it as administrator, try running it in xp compatibility mode, install the Source SDK's and make sure the game is set to the Orange Box (not sure if this does anything but it can't hurt) or if it's already installed try resetting the configuration: https://developer.valvesoftware.com/wiki/Reset_the_Source_SDK_Game_Configuration

Also check this: https://developer.valvesoftware.com/wiki/The_Game_Directory
nailbiter 28. Okt. 2012 um 17:20 Uhr 
running into same problem.. can't even launch the SFM SDK or Hammer.exe. SFM runs fine though.
PC's_Frank 29. Okt. 2012 um 17:23 Uhr 
Hammer's been doing all kinds of weird things all weekend. I think it has to do with the TF2 update.
[NIИ]Complication 4. Nov. 2012 um 1:55 Uhr 
does anyone have any solution to this?
Zuletzt bearbeitet von [NIИ]Complication; 4. Nov. 2012 um 1:55 Uhr
[NIИ]Complication 4. Nov. 2012 um 3:37 Uhr 
I FOUND THE SOLUTION.

Somehow somewhere GameConfig.txt has been deleted after update.

You have to put this file in SFM bin directory where hammer sits

"Configs"
{
"Games"
{
"usermod"
{
"GameDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod"
"Hammer"
{
"GameData0" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\tf.fgd"
"TextureFormat" "5"
"MapFormat" "4"
"DefaultTextureScale" "0.250000"
"DefaultLightmapScale" "16"
"GameExe" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\sfm.exe"
"DefaultSolidEntity" "func_detail"
"DefaultPointEntity" "info_player_teamspawn"
"BSP" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vbsp.exe"
"Vis" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vvis.exe"
"Light" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vrad.exe"
"GameExeDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game"
"MapDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\content\usermod\mapsrc"
"BSPDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod\maps"
"PrefabDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\Prefabs"
"CordonTexture" "tools\toolsskybox"
MaterialExcludeCount" "0"
}
}
}
"SDKVersion" "5"
}

Obviously you have to replace "YOUR STEAM FOLDER" with full path, including drive, where your steam is installed, for example C:\Program Files\Steam\etc etc
Squid (Asshat) 4. Nov. 2012 um 8:55 Uhr 
I did the above solution and it still won't launch.
INϟANE★Aka♠ 16. Juni 2013 um 3:14 Uhr 
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?
raptornx01 16. Juni 2013 um 4:25 Uhr 
Ursprünglich geschrieben von <SaVaGe> INSANE^Aka:
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?

where are you launching from?
Beiträge 1-12 von 12
< >
Pro Seite: 15 30 50
Geschrieben am: 28. Okt. 2012 um 16:16 Uhr
Beiträge: 12