Source Filmmaker > Algemene discussies > Details van topic
The Seemingly Innocuous Squid 28 okt 2012 om 4:16nm
SFM Hammer won't start
Is there a reason why it won't start? Can I fix it? Help!
1-12 van 12 reacties weergegeven
< >
PalmliX 28 okt 2012 om 4:43nm 
What happens exactly when you try and run it?
The Seemingly Innocuous Squid 28 okt 2012 om 4:48nm 
I click on hammer.exe in the SFM bin folder, and it won't start up.
PalmliX 28 okt 2012 om 4:59nm 
you mean nothing happens? no error or anything?
The Seemingly Innocuous Squid 28 okt 2012 om 5:02nm 
Nothing happens. No errors, nothing.
PalmliX 28 okt 2012 om 5:13nm 
Try running it as administrator, try running it in xp compatibility mode, install the Source SDK's and make sure the game is set to the Orange Box (not sure if this does anything but it can't hurt) or if it's already installed try resetting the configuration: https://developer.valvesoftware.com/wiki/Reset_the_Source_SDK_Game_Configuration

Also check this: https://developer.valvesoftware.com/wiki/The_Game_Directory
nailbiter 28 okt 2012 om 5:20nm 
running into same problem.. can't even launch the SFM SDK or Hammer.exe. SFM runs fine though.
PC's_Frank 29 okt 2012 om 5:23nm 
Hammer's been doing all kinds of weird things all weekend. I think it has to do with the TF2 update.
[NIИ]Complication 4 nov 2012 om 1:55vm 
does anyone have any solution to this?
Laatst bewerkt door [NIИ]Complication; 4 nov 2012 om 1:55vm
[NIИ]Complication 4 nov 2012 om 3:37vm 
I FOUND THE SOLUTION.

Somehow somewhere GameConfig.txt has been deleted after update.

You have to put this file in SFM bin directory where hammer sits

"Configs"
{
"Games"
{
"usermod"
{
"GameDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod"
"Hammer"
{
"GameData0" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\tf.fgd"
"TextureFormat" "5"
"MapFormat" "4"
"DefaultTextureScale" "0.250000"
"DefaultLightmapScale" "16"
"GameExe" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\sfm.exe"
"DefaultSolidEntity" "func_detail"
"DefaultPointEntity" "info_player_teamspawn"
"BSP" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vbsp.exe"
"Vis" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vvis.exe"
"Light" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vrad.exe"
"GameExeDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game"
"MapDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\content\usermod\mapsrc"
"BSPDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod\maps"
"PrefabDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\Prefabs"
"CordonTexture" "tools\toolsskybox"
MaterialExcludeCount" "0"
}
}
}
"SDKVersion" "5"
}

Obviously you have to replace "YOUR STEAM FOLDER" with full path, including drive, where your steam is installed, for example C:\Program Files\Steam\etc etc
The Seemingly Innocuous Squid 4 nov 2012 om 8:55vm 
I did the above solution and it still won't launch.
Aka 16 jun 2013 om 3:14vm 
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?
raptornx01 16 jun 2013 om 4:25vm 
Origineel geplaatst door <SaVaGe> INSANE^Aka:
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?

where are you launching from?
1-12 van 12 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 28 okt 2012 om 4:16nm
Aantal berichten: 12