Source Filmmaker

Source Filmmaker

Squid From UNATCO 28. okt 2012 kl. 16:16
SFM Hammer won't start
Is there a reason why it won't start? Can I fix it? Help!
< >
Viser 1-12 af 12 kommentarer
PalmliX 28. okt 2012 kl. 16:43 
What happens exactly when you try and run it?
Squid From UNATCO 28. okt 2012 kl. 16:48 
I click on hammer.exe in the SFM bin folder, and it won't start up.
PalmliX 28. okt 2012 kl. 16:59 
you mean nothing happens? no error or anything?
Squid From UNATCO 28. okt 2012 kl. 17:02 
Nothing happens. No errors, nothing.
PalmliX 28. okt 2012 kl. 17:13 
Try running it as administrator, try running it in xp compatibility mode, install the Source SDK's and make sure the game is set to the Orange Box (not sure if this does anything but it can't hurt) or if it's already installed try resetting the configuration: https://developer.valvesoftware.com/wiki/Reset_the_Source_SDK_Game_Configuration

Also check this: https://developer.valvesoftware.com/wiki/The_Game_Directory
nailbiter 28. okt 2012 kl. 17:20 
running into same problem.. can't even launch the SFM SDK or Hammer.exe. SFM runs fine though.
PC's_Frank 29. okt 2012 kl. 17:23 
Hammer's been doing all kinds of weird things all weekend. I think it has to do with the TF2 update.
does anyone have any solution to this?
Sidst redigeret af [NIИ]Complication; 4. nov 2012 kl. 1:55
I FOUND THE SOLUTION.

Somehow somewhere GameConfig.txt has been deleted after update.

You have to put this file in SFM bin directory where hammer sits

"Configs" { "Games" { "usermod" { "GameDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod" "Hammer" { "GameData0" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\tf.fgd" "TextureFormat" "5" "MapFormat" "4" "DefaultTextureScale" "0.250000" "DefaultLightmapScale" "16" "GameExe" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\sfm.exe" "DefaultSolidEntity" "func_detail" "DefaultPointEntity" "info_player_teamspawn" "BSP" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vbsp.exe" "Vis" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vvis.exe" "Light" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\vrad.exe" "GameExeDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game" "MapDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\content\usermod\mapsrc" "BSPDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\usermod\maps" "PrefabDir" "YOUR STEAM FOLDER\SteamApps\common\SourceFilmmaker\game\bin\Prefabs" "CordonTexture" "tools\toolsskybox" MaterialExcludeCount" "0" } } } "SDKVersion" "5" }

Obviously you have to replace "YOUR STEAM FOLDER" with full path, including drive, where your steam is installed, for example C:\Program Files\Steam\etc etc
Squid From UNATCO 4. nov 2012 kl. 8:55 
I did the above solution and it still won't launch.
∃NI 16. jun 2013 kl. 3:14 
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?
raptornx01 16. jun 2013 kl. 4:25 
Oprindeligt skrevet af <SaVaGe> INSANE^Aka:
i have another problem . then i start hammer, model viwer, face poser or itemtest it gives error "the configuration of the game you are trying to edit is invalid or missing" what i must to do ?

where are you launching from?
< >
Viser 1-12 af 12 kommentarer
Per side: 15 30 50

Dato opslået: 28. okt 2012 kl. 16:16
Indlæg: 12