Source Filmmaker > 综合讨论 > 主题详情
GreenArrow - The Hood 2013年10月1日下午3:09
SFM crash
Hello...i need some help cuz my SFM crash every time i shoot in the game mode. a few weeks ago it was good, nothing make it crash it.. it never crashed but now im tired, has been 1 week of it and it also crash randomly when i posing the puppets or something, it is awful it crashes for nothing i really need a hand
正在显示第 1 - 13 条,共 13 条留言
< >
Pte Jack 2013年10月1日下午6:06 
Validate your Local Cache and launch through the SDK
GreenArrow - The Hood 2013年10月1日下午6:31 
引用自 Pte Jack
Validate your Local Cache and launch through the SDK
how do i validate my local cache?
Pte Jack 2013年10月1日下午7:15 
Steam Client, Library, All Softwares, Right Click SFM, Properties, Local Files, Verify Integrity of Application Cache Let the process complete and all missing content download, restart SFM and try again
GreenArrow - The Hood 2013年10月1日下午9:03 
引用自 Pte Jack
Steam Client, Library, All Softwares, Right Click SFM, Properties, Local Files, Verify Integrity of Application Cache Let the process complete and all missing content download, restart SFM and try again

NOPE, still crashing this ♥♥♥♥ im so tired
Pte Jack 2013年10月2日上午12:23 
Are you loading custom models or maps... That can cause crashes as well..
Gnome Compsci 2013年10月2日上午10:44 
What kind of “crash” is it? Does it leave an error message? Does the program freeze or quit to desktop?
GreenArrow - The Hood 2013年10月2日上午11:53 
引用自 Gnome Compsci
What kind of “crash” is it? Does it leave an error message? Does the program freeze or quit to desktop?

quit to desktop
GreenArrow - The Hood 2013年10月2日上午11:53 
引用自 Pte Jack
Are you loading custom models or maps... That can cause crashes as well..

but i had the customs like 3 months ago and now it crashes
Johano™ 2013年10月2日下午1:30 
Make sure you've installed the files in {STEAMDIR}/Steamapps/Common/Sourcefilmmaker/_CommonRedist

That fixed my crash :)
GreenArrow - The Hood 2013年10月2日下午1:57 
引用自 Johano™
Make sure you've installed the files in {STEAMDIR}/Steamapps/Common/Sourcefilmmaker/_CommonRedist

That fixed my crash :)

i dint, i put the files on the usermode one... but i got alooot of custom files, what should i do? delete SFM and then install it again? and then download all the custom files again?
最后由 GreenArrow - The Hood 编辑于; 2013年10月2日下午1:58
Gnome Compsci 2013年10月2日下午2:10 
Try renaming the usermod folder to oldUsermod or something, then use Fix Cache Integrity and run SFM.
This should point out whether or not the fault lies with a custom file or something else. If it still crashes you still have your custom objects which can be brought back just by renaming the folder back.
GreenArrow - The Hood 2013年10月2日下午3:35 
引用自 Gnome Compsci
Try renaming the usermod folder to oldUsermod or something, then use Fix Cache Integrity and run SFM.
This should point out whether or not the fault lies with a custom file or something else. If it still crashes you still have your custom objects which can be brought back just by renaming the folder back.

OMG thankls aloot now i can shoot with all classes withput it crashes, im experiencing problems with my custom content but im doing the copy and paste to get all of them back
thaaanks thaanks thaaanks

最后由 GreenArrow - The Hood 编辑于; 2013年10月2日下午3:52
GreenArrow - The Hood 2013年10月2日下午7:37 
引用自 Gnome Compsci
Try renaming the usermod folder to oldUsermod or something, then use Fix Cache Integrity and run SFM.
This should point out whether or not the fault lies with a custom file or something else. If it still crashes you still have your custom objects which can be brought back just by renaming the folder back.

ok now i can shoot and some particles that used to not show up now they do..but the thing is that it crash about every time just in the primary viewport or doing something else, it random crashs again, what should i do?
最后由 GreenArrow - The Hood 编辑于; 2013年10月2日下午8:33
正在显示第 1 - 13 条,共 13 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年10月1日下午3:09
帖子数: 13