Corky The Guar Sep 12, 2013 @ 6:49pm
Help with resizing models / GUIStudio Master failed to take master pipe connection lock
Edit: I changed the topic's name so that it was more relivant to the discussion.

Here's what it used to say:

I know there are ways to do this outside of SFM, but I've ran into so many bugs and crashes that I've pretty much given up using the third party programs. What I am asking is if Valve is planning on adding this ability into SFM itself.
Last edited by Corky The Guar; Sep 12, 2013 @ 10:42pm
Showing 1-15 of 37 comments
< >
raptornx01 Sep 12, 2013 @ 7:16pm 
Well, you can do it using models as particles (kind of). so presumably there is a way. most likely it will only be as fanmade scripts (unless there already is a way and we just haven't found it yet).
Corky The Guar Sep 12, 2013 @ 7:20pm 
What do you mean by "Fanmade scripts"? Are there ways to mod source filmmaker with external scripts?
raptornx01 Sep 12, 2013 @ 7:27pm 
yes. there are a few.

look on sfmbox.com most of the known ones are there.

there is one more for being able to animate the timescale of particles, but i forget where i found it.
PalmliX Sep 12, 2013 @ 7:30pm 
This would be a great feature to have, and yes raptornx is right, you can re-scale models using a particle system but certain limitations apply.
Corky The Guar Sep 12, 2013 @ 7:37pm 
Huh. I wish I had known about these scripts sooner! The DotA 2 Multi-Part Assembly Script is amazing.

Do any of you know how to change the size of an object using particles?
Pte Jack is away for a MONTH Sep 12, 2013 @ 8:23pm 
You can always rescale like this if you have the know how...

http://steamcommunity.com/sharedfiles/filedetails/?id=130411318
Corky The Guar Sep 12, 2013 @ 8:26pm 
I spent (litterally) all of last night attempting that very tutorial. I ran into so many bugs and crashes until I found one that was pretty much unsolvable. (As in, not even google could find an answer) I am beginning to think it's because of my OS, which is Windows 8.

I got as far as re-compiling the decompiled models to see if it would work, which I got several different errors relating to the launching of steam or something along those lines. Google showed me various different cases with the same error, but none of the solutions that worked for them worked for me.

I made this post to suggest / to look for other alternatives because that doesn't seem to work for everyone.
Last edited by Corky The Guar; Sep 12, 2013 @ 8:32pm
Pte Jack is away for a MONTH Sep 12, 2013 @ 9:03pm 
Hmmm, I use windows 8 and that is one of my guides, so it must be because of some of the settings you've made on your system that may be causing problems. I guess knowing which models you are trying to resize would help and which programs are erring out as well. If you are getting all the way through to compiling the model, what is the error you're encountering?
Corky The Guar Sep 12, 2013 @ 9:09pm 
The model I was using was the cop sunglasses owned by the heavy. The most prominent error I recieved using GUIStudioMDL was:

SteamStartup() failed: SteamStartup(0xf,0x0017F170) failed with error 1: failed to take master pipe connection lock

There were others, but I can't remember them at this time. Sources across google said to simply restart your computer / steam or to delete some .blob file, but none of those fixed the problem. I have also tried running both steam and GUIStudio as admin.


Last edited by Corky The Guar; Sep 12, 2013 @ 9:12pm
Corky The Guar Sep 12, 2013 @ 9:37pm 
Here's a few more of the errors: (None of these occur at once)

SteamStartup() failed: SteamStartup(0xf,0x008BF3C8) failed with error 1: Failed create pipe: 6, Win32 Error 6 "The handle is invalid."

MountFilesystem( 41013 ) failed: SteamMountFilesystem(1520,41013,0x354fb50=,0x354fa40) failed with error 5: No CS online with App 41013 Ver 25

As a sidenote, I have been unable to find the EP1 directory. It tells me it cannot find the gameconfig.txt, however I do not believe this is the problem because I use the OrangeBox, not ep1.

Last edited by Corky The Guar; Sep 12, 2013 @ 9:48pm
Pte Jack is away for a MONTH Sep 12, 2013 @ 10:15pm 
Dag Pipeline!!!

I think I'm going to have to completly delete EVERYTHING Steam from one of my computers and reload everything again just to find out how much damage the Pipeline Upgrade screwed everything up. I kind of want to stay away from doing that though because it over a 100 gig download for me to get everything back again. But I think I'm going to have to do it because the way I have things set up right now, I'm having some good luck.

But, I know that I have added game files from the old game configurations and folders to beat the system for some of my models. But I have had to modified things so much, I am not sure what is correct and what is an add anymore.
Corky The Guar Sep 12, 2013 @ 10:17pm 
Ah. do you have the same error now too?
Corky The Guar Sep 12, 2013 @ 10:34pm 
I managed to fix the compiling problem! And that was by creating a batch file with the following text:

echo off
title compiling QC for %* using studiomdl.bat
color 4F
"C:\Program Files (x86)\Steam\steamapps\common\SourceFilmmaker\game\bin\studiomdl.exe" -verbose -game "C:\Program Files (x86)\Steam\steamapps\common\SourceFilmmaker\game\usermod" %*
pause

To use this batch file, just drag your QC file over it and it will compile.

My new problem NOW is $scale doesn't appear to be affecting anything. Is the following placement unacceptable?

$cd "C:\Users\Chadd\Desktop\New Models\Decompile"
$modelname "player/items/heavy/cop_glasses.mdl"
$scale 2
$model "body" "cop_glasses.dmx.smd"
$cdmaterials "\models\player\items\heavy\"
$cdmaterials ""
$texturegroup skinfamilies
Last edited by Corky The Guar; Sep 12, 2013 @ 10:35pm
Pte Jack is away for a MONTH Sep 12, 2013 @ 10:37pm 
No, I'm one of those guys that keep back ups of backups. If I run into a problem because of an upgrade I search for files that were removed and bass_tard_dize my system so that it works. Since pipeline really screwed up most of the old decompilers and compilers, I've added old file to the where they use to be just to keep things working. (The old TF2 folders under the userid is a prime example.) But, now that the SDK has moved to SDK2013, I have no idea where to point things to anymore. That's why I'm going to have to strip one of my computers and set it up to the current Steam configurations. Just to see what is what and see what pipeline really broke and if there is a fix in today's configurations. Dag Pipeline!!!
Corky The Guar Sep 12, 2013 @ 10:38pm 
Ouch. That sounds like a painful experience.
Showing 1-15 of 37 comments
< >
Per page: 15 30 50
Date Posted: Sep 12, 2013 @ 6:49pm
Posts: 37