Christmas Dragon In A Sombrero 25 aug, 2013 @ 1:20pm
Rigged finger posing
Whenever I add a rig_biped_simple to a tf2 character ( I haven't tried with any other models yet), and try to pose the fingers of any model, my SFM lags really bad and it becomes hard to pose fingers. Yes, I can still pose them, but it's very hard to get accurate finger poses that I want. Anyone know any solutions/ why this is happening?
Thanks.
Visar 1-14 av 14 kommentarer
< >
Pte Jack Wishes Merry Christmas 25 aug, 2013 @ 1:48pm 
Try turning off progressive refinement, your graphics card may not be 100% compatible with SFM (ie just meets requirement or maybe an Intel based card, they seem to have a lot of problems with SFM).

I don't have any problems with moving fingers, even when I have them all combined and rotating them using local rotations with my Radeon cards or with my Radeon mobility chipset on my laptop.
Christmas Dragon In A Sombrero 25 aug, 2013 @ 2:00pm 
Well I'm confused now. I've turned off progressive refinement, and the problem still persists, I'm still getting about 1.9 fps and I don't see it being the intel issue, as my laptop is 100% AMD graphics card and processor. Could it be my GHz of my laptop? (1.9 GHz) ((I dare not overclock it as I hear it makes your fans heat up a lot more and my laptop already has overheating problems as it is))
Pte Jack Wishes Merry Christmas 25 aug, 2013 @ 2:19pm 
Mines an Intel Core i7 740QM @ 1.73GHz with a 1024MB ATI Mobility Radeon HD 5800 Series Chipset. I have no probs posing fingers. Don't know what to tell you and I don't turn off PR either.
Senast ändrad av Pte Jack Wishes Merry Christmas; 25 aug, 2013 @ 2:19pm
Christmas Dragon In A Sombrero 25 aug, 2013 @ 2:20pm 
That's probably where it is, mine's only a Quad Core AMD A8-3530MX APU
Pte Jack Wishes Merry Christmas 25 aug, 2013 @ 2:54pm 
My phenom 4's (945 and 955) with 6000 and 7000 Radeons work fine as well (Desktops)
R234 25 aug, 2013 @ 3:38pm 
It's normal, IK rigged model's fingers sometimes take a while to calculate in SFM. It's an inherent bug or limitation or something. The only workaround is to unrig the model to work with the fingers.
Pte Jack Wishes Merry Christmas 25 aug, 2013 @ 4:18pm 
Strange, I don't have that problem, with the model rigged or unrigged. I wonder if it would be faster if you're working in offline mode?
R234 25 aug, 2013 @ 4:31pm 
I wouldn't be surprised if that issue was only present on some machines, that wouldn't nearly be the only one to do that. From my own observation though, it seems it only happens sometimes, mostly when there's a lot of transform locks involved.

Without going into too much details, my current movie has a scene where a Spy piggybacks a Heavy. For the Heavy's motion to translate well onto the Spy, I IK rigged the latter, locked his feet to the Heavy's pelvis and his hands to the Heavy's shoulders. Manipulating his fingers then ran at about 1 fps. If it can make my 8-core I7 with a GTX 770 tank like that, it can't be related to computer strength now can it?
Christmas Dragon In A Sombrero 25 aug, 2013 @ 11:02pm 
@R234 Yeah, I usually unrig the model to work with the fingers, but I don't like doing that as sometimes (for me at least) when I switch back to normal models, when you press ctrl to view the bones on the model, some bones are not there and you have to navigate through the library and me, (Being the impatient person that I am) get really annoyed at this :P
Senast ändrad av Christmas Dragon In A Sombrero; 25 aug, 2013 @ 11:02pm
R234 26 aug, 2013 @ 12:09am 
Yeah, that's annoying, but you can click the arrow-shaped "selectable" icon to the left of the joint names to make them visible in the viewport again.
Circle Pipe 26 aug, 2013 @ 12:11am 
Unrigging is a really annoying thing to do. I prefer finger presets (https://www.dropbox.com/sh/msbfj16w4us73nn/V7N8WrAWcP). Put these in your Sourcefilmmaker/game/tf_movies/models/player/hwm.

When in IK just adjust the sliders for the hands like you would adjust emotions. The preset contains flat/pointing hands and fists
Senast ändrad av Circle Pipe; 26 aug, 2013 @ 12:12am
( ͡° ͜ʖ ͡°) stabkamay 26 aug, 2013 @ 2:49am 
that's a common thing I think that's nothing bad as far as I know..
Ghost 26 aug, 2013 @ 1:40pm 
i say,why not make rigs for fingers too.Or at least,some presets/sequenceses
The Doctor 26 aug, 2013 @ 2:07pm 
I get this problem sometimes, when I'm starting a project. But at some point while I'm working on it, it stops lagging at all. Dunno why it happens, but it does tend to resolve itself as you keep working.
Visar 1-14 av 14 kommentarer
< >
Per sida: 15 30 50
Datum skrivet: 25 aug, 2013 @ 1:20pm
Inlägg: 14