Source Filmmaker

Source Filmmaker

raptornx01 24 août 2013 à 8h48
A way to make body parts invisible
Say you have a model made up of multiple smds. and you can see them when you right-click and look under bodygroups. is it possible to hide just one smd, or would the model have to be recompiled?

possibly with override materials?

EDIT: I found it. right-click, add override material. then right-click and open model in element viewer. go down to materials. expand it. find the part you want to hide* right-click and go to add attribute. select float. then type in $alpha

*if the part you want isn't listed just right-click materials and go to add element. then name it whatever name the piece is (has to be the exact name. and the location of the vtf file in the materials folder for that part.
Dernière modification de raptornx01; 24 août 2013 à 10h55
< >
Affichage des commentaires 1 à 7 sur 7
EmperorFaiz.ded 25 août 2013 à 2h45 
thank you for the tips, amigo
Dernière modification de EmperorFaiz.ded; 25 août 2013 à 2h45
Puzzler 25 août 2013 à 11h58 
Thanks! You are awesome!
raptornx01 3 sept 2013 à 19h04 
Ok I did a video showing how this is done.
Weezer 4 sept 2013 à 17h37 
what is that abomination flying on my screen as i watch this video, but nice animation :|

raptornx01 a écrit :
Ok I did a video showing how this is done.
Sarsour 6 sept 2013 à 1h29 
I duno if this would help but in the console you can type in ' toolload vmt '
brings up some material settings... also toolunload vmt when you wanna close it (or else it stays open in the background)
Dernière modification de Sarsour; 6 sept 2013 à 4h27
raptornx01 6 sept 2013 à 2h48 
That.... did nothing. it says the material editor is loaded, but i see no extra options anywhere, and no window popped up. unless i'm missing something.

EDIT: ok, it's in the game engine window. select a vmt. annnnndd it crashed the program :/

EDIT 2: it seems like it COULD be useful, but it actually does edit the vmts. which is fine if the change you want to do you want to be permanent. but the preview windows and thing are pretty much useless. and you can't actually see what you are doing to the model.

and it still only works if the texture actually HAS a vmt.

Plus it's buggy as hell. I did like I do with the particle editor and went to tools and selected sfm, then the texture that I had been looking at the vmt for unloaded itself to be replaced with the purple and black checker we are so familiar with. and on top of that, for an odd change of pace, the program couldn't be shut down. it would give me the pop up asking if i wanted to save. I'd click don't save, and..... nothing. and nothing I did could close it. I actually had to ctrl alt delete it to get it to close.

That being said, good find. I'll keep this i mind just in case. But I think the override materials would be more useful.
Dernière modification de raptornx01; 6 sept 2013 à 3h16
Sarsour 6 sept 2013 à 4h25 
to unload it/ close it , press f11 to go back to the ingame mode and bring up the console and type in toolunload vmt ....but yes it is very buggy, would be a nice feature if they could fix it for atleast the release version of sfm.
< >
Affichage des commentaires 1 à 7 sur 7
Par page : 15 30 50