Source Filmmaker > 일반 토론 > 제목 정보
yvaNNe 2013년 8월 23일 오전 3시 32분
Map Crash..
Whenever I start sfm, and I load up a new project, click "load map" and select a map, my source film maker stops responding. It doesn't even show the 'sfm.exe has stopped responding' window, it just closes. I have high computer specs, I can run BF3 and most high-end games without difficulty. I'm using a PC. Help?
yvaNNe님이 마지막으로 수정; 2013년 8월 23일 오전 3시 35분
7개 중 1-7 표시중
< >
raptornx01 2013년 8월 23일 오전 5시 47분 
which map? also, what system specs?

And I find, SFM often doesn't have pop-ups are "this program has crashed" things. it just closes.
yvaNNe 2013년 8월 23일 오전 5시 48분 
Map is CP_Badlands, and the problem fixed itself. For some reason specific maps have a habit of crashing my SFM. but theres so little maps which do this that I can probably go on without it.
Pte Jack 2013년 8월 23일 오전 8시 00분 
Yvanne, there have been changes to the backend of SFM. Sometimes that causes reciprocating problems and probably why it doesn't work one day then works the next. I personally wish that Valve would finish their updates to the pipeline so that we can get on with stuff. Man, my head feels like a yo-yo working behind the scenes with models and the SDKs. Worked Yesterday, works tomorrow, but never never works today!!!

Just tried loading cp_badlands, I get the same result. CRASH!!! No warning, just down and out.
Pte Jack님이 마지막으로 수정; 2013년 8월 23일 오전 8시 36분
Pte Jack 2013년 8월 23일 오전 9시 03분 
Follow up, I decompiled the cp_badlands and tried to get it into the SFM version of Hammer. That crashed Hammer, did not matter how I tried to run Hammer. The map would get to about 5% in the postload process, report an error, ask me if I wanted to resave the map, if I answered yes, Hammer Crashed, if I answered No, the postload process would continue to about 98% and crashed Hammer.

I've found the TF2 source map for CP_Badlands, I've loaded that into the TF2 MP version of Hammer. Found that HDR is not turned on in that map, so I am in the process of using that version of Hammer to re-run the map with HDR turned on. We'll see where that get's us. Not sure how long this is going to take.
Pte Jack 2013년 8월 23일 오전 9시 16분 
WELL, Brushes don't join errors, leaks all over the place and the src is marked read only, can not save map.... WOW!!! Let's try this a different way.
Pte Jack님이 마지막으로 수정; 2013년 8월 23일 오전 9시 17분
Pte Jack 2013년 8월 23일 오전 10시 33분 
Nope, I am not having any luck with this... I fixed all the errors that were reported by use the Check For Problems function and tried to compile the map (run it) in Hammer. I get to the same point everytime and the compile crashes during the VBSP function. Even though Hammer now isn't reporting any error in the map when I click Check for Problems, VBSP function tells me that areaportal Brushes 27242, 26847 and 26855 are not touching 2 areas, Entity Prop_Static (-1076.32 -1101.06 0.18) Leaked, Env_cubemap is pointing at deleted brushsides, good matches could not be found for a bunch of brushes, Merging Details give waring about falling out of small block heap and tht make_triangles:calc_triangle_representations can't be converted before IT (VBSP) crashes.

Not personally being a Mapper doesn't help either, I can only guess why these errors are happening. It's a huge map with a lot of stuff in it. I haven't the knowledge to zoom in on the problem to fix it.
yvaNNe 2013년 8월 23일 오후 4시 57분 
Thanks Jack... much more indepth response(s) then I thought I'd get :P I guess I'll just use other maps for now. Also, I found out something rather interesting. Although CP_Badlands doesn't seem to work, arena_badlands does. Dunno what that means, but thanks for your time.
yvaNNe님이 마지막으로 수정; 2013년 8월 23일 오후 5시 00분
7개 중 1-7 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 8월 23일 오전 3시 32분
게시글: 7