Dawg Aug 20, 2013 @ 4:44pm
imf.dll
I keep getting this error when trying to luanch sourcefilm maker
"unable to load ifm.dll"
Showing 1-13 of 13 comments
< >
Pte Jack Aug 20, 2013 @ 5:44pm 
Close and restart your steam client and try again.
Dawg Aug 20, 2013 @ 6:31pm 
I have tried that, I have also tried reinstalling SFM + running integrity check many time's..
Still couldnt get the darned thing to run . Finally checked to see if file was even present and it wasnt.. Not sure where to get this file and/or if I even want to Dl it from the net.
Pte Jack Aug 20, 2013 @ 6:57pm 
The imf.dll file is located in the C:\Program Files (x86)\Steam\steamapps\common\SourceFilmmaker\game\bin\tools along with 3 other dll files.

Commedit.dll, pet.dll and vmt.dll

Check to see if this fold exists and that the other 3 are there...
Last edited by Pte Jack; Aug 20, 2013 @ 6:57pm
Dawg Aug 20, 2013 @ 7:23pm 
Confirmed,They are there.
Pte Jack Aug 20, 2013 @ 8:08pm 
but the imf.dll is missing?
Also what are the dates on the other 3?

Last edited by Pte Jack; Aug 20, 2013 @ 8:09pm
Dawg Aug 20, 2013 @ 8:11pm 
imf.dll is present
Dates are all today's date 8/20/13
Pte Jack Aug 20, 2013 @ 8:30pm 
Did you try launching through the SFM SDK Tool menu?
Another thing, (you may have already tried this) Launch Steam as an administrator
Last edited by Pte Jack; Aug 20, 2013 @ 8:32pm
raptornx01 Aug 20, 2013 @ 8:37pm 
just to be sure, what is the error again, exactly? does it say ifm, or imf?

sounds stupid I know, but have to ask.
Last edited by raptornx01; Aug 20, 2013 @ 8:37pm
Dawg Aug 20, 2013 @ 8:39pm 
Originally posted by Pte Jack:
Did you try launching through the SFM SDK Tool menu?
Another thing, (you may have already tried this) Launch Steam as an administrator
Yes
Dawg Aug 20, 2013 @ 8:40pm 
Originally posted by raptornx01:
just to be sure, what is the error again, exactly? does it say ifm, or imf?

sounds stupid I know, but have to ask.
Unable to load ifm.dll
Pte Jack Aug 20, 2013 @ 10:33pm 
Sorry, dyslexic... lol!!!
Wait!!! no I'm not... Check the file ref in the topic heading... imf.dll Then he changed it... DOH!!!

And I should have said the "ifm.dll" is in C:\Program Files (x86)\Steam\SteamApps\common\SourceFilmmaker\game\bin\tools folder with the other 3.

If it is there, then you are having a load problem.

Close Steam, REBOOT your computer, and try again.

(Man I just search over 554,958 files in my steam folders looking for IFM.DLL thinking mine was IMF.DLL, rooted through about 20 .lst, .txt and .dic files line by line looking for a ref to ifm.dll to try and find where it was hidden, only to find that I was staring at all a long. It wasn't until I got the 11,284 dlls segregated that I found that I had already found it the first time. What a maccaroon I am!!! )

I have 1 other trick to try if that doesn't work.
Last edited by Pte Jack; Aug 20, 2013 @ 10:36pm
Dawg Aug 21, 2013 @ 6:49am 
Its my bad, Looks like I made the topic IMF.DLL .. so that one's on me , LOL
any ways i have tried rebooting/integrity check's/reinstall/steam reinstall/open as admin.
kinda wondering if its not becuase I just installed this OS and I only got the upgrades I needed. So maybe I am missing some visual c++ or something like that. I will try this today and see if it fixes the issue. I really apreciate you takin the time to try and help me out. +rep
Pte Jack Aug 21, 2013 @ 10:25am 
It is best to ensure that your OS is up-to-date, but I have a bad feeling that updating is not going to help in this situation. I have read that some ppl with launch problems fix them by deleting the ClientRegistry.blob found in the C:\Program Files (x86)\Steam folder. I have also read that deleting this file can break Steam.

Try that if you dare, but the other trick I was referring to is to opt into the Steam Client Beta program, this will download a newer version of your client and reset the config file.

To do this, launch Steam. In the Menu options Goto Steam/Settings. On the accounts tab, in the Beta Participation section click Change. Change None - Opt Out to Steam Beta Participation. Click OK. Close the client and Reboot (Reboot isn't really necessary, just a practice I got into when I install, update or change a program configuration), Load Steam (if it isn't set to start when Windows opens) and wait for it to update. When it's loaded try SFM again. If SFM starts or if it doesn't, you can go back and opt out again, close everything, reboot and try SFM again. At least you'll know that it's not the client causing the problem and will have the most up-to-date version of it.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Aug 20, 2013 @ 4:44pm
Posts: 13