Source Filmmaker

Source Filmmaker

Source Filmmaker > 一般討論 > 主題細節
MLTDG 2013 年 07 月 31 日 @ 下午 1 時 23 分
Firing weapons crashes the program
Every time I enter game mode and try to fire ANY weapon, SFM completely locks up, then crashes. I've tried the obvious solutions (verifying my cache, launching SFM through SDK, etc.), but they didn't work. I want to know (a) what is causing this, and (b) how to fix it.
< >
顯示 1-9,共 9 則回應
PlayerZERO 2013 年 07 月 31 日 @ 下午 1 時 34 分 
Does it happen w/ melee weapons, too?
MLTDG 2013 年 07 月 31 日 @ 下午 2 時 51 分 
PlayerZERO 發表:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg 2013 年 07 月 31 日 @ 下午 6 時 48 分 
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
最後修改者:SamSpielberg; 2013 年 07 月 31 日 @ 下午 6 時 48 分
PlayerZERO 2013 年 07 月 31 日 @ 下午 6 時 50 分 
MLTDG 發表:
PlayerZERO 發表:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg 發表:
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Actually, the red X thing happened to me before the update.
R234 2013 年 07 月 31 日 @ 下午 6 時 54 分 
Have you tried restarting Steam since the update? I hear that sometimes works.
MLTDG 2013 年 07 月 31 日 @ 下午 7 時 09 分 
R234 發表:
Have you tried restarting Steam since the update? I hear that sometimes works.
That might work. I'll try it.
MLTDG 2013 年 07 月 31 日 @ 下午 9 時 57 分 
I just restarted Steam, loaded the tf-movies "box" map, and attempted to fire Scout's scattergun. The program locked up for several minutes, THEN crashed--this time with an error message.

So, in other words, restarting Steam didn't help much, if at all.
ℳAℐZℰ 2013 年 08 月 23 日 @ 下午 3 時 33 分 
MLTDG, Try this, this fixed my problem.

Go to your usermod folder, backup your particles folder and delete it.

If you dont have a particles folder, you might be dealing with something else.
MLTDG 2013 年 08 月 23 日 @ 下午 7 時 26 分 
I'll give that a try.

Update: I deleted my usermod\particles folder, like you suggested, and it worked!
最後修改者:MLTDG; 2013 年 08 月 23 日 @ 下午 7 時 39 分
< >
顯示 1-9,共 9 則回應
每頁: 15 30 50

Source Filmmaker > 一般討論 > 主題細節
張貼日期: 2013 年 07 月 31 日 @ 下午 1 時 23 分
回覆: 9