Source Filmmaker > Общие обсуждения > Подробности темы
MLTDG 31 июл, 2013 @ 13:23
Firing weapons crashes the program
Every time I enter game mode and try to fire ANY weapon, SFM completely locks up, then crashes. I've tried the obvious solutions (verifying my cache, launching SFM through SDK, etc.), but they didn't work. I want to know (a) what is causing this, and (b) how to fix it.
Показано 19 из 9 комментариев
< >
PlayerZERO 31 июл, 2013 @ 13:34 
Does it happen w/ melee weapons, too?
MLTDG 31 июл, 2013 @ 14:51 
Изначально опубликовано PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg 31 июл, 2013 @ 18:48 
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Последний раз отредактировал SamSpielberg; 31 июл, 2013 @ 18:48
PlayerZERO 31 июл, 2013 @ 18:50 
Изначально опубликовано MLTDG:
Изначально опубликовано PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
Изначально опубликовано SamSpielberg:
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Actually, the red X thing happened to me before the update.
R234 31 июл, 2013 @ 18:54 
Have you tried restarting Steam since the update? I hear that sometimes works.
MLTDG 31 июл, 2013 @ 19:09 
Изначально опубликовано R234:
Have you tried restarting Steam since the update? I hear that sometimes works.
That might work. I'll try it.
MLTDG 31 июл, 2013 @ 21:57 
I just restarted Steam, loaded the tf-movies "box" map, and attempted to fire Scout's scattergun. The program locked up for several minutes, THEN crashed--this time with an error message.

So, in other words, restarting Steam didn't help much, if at all.
Honey Bunches of Swag 23 авг, 2013 @ 15:33 
MLTDG, Try this, this fixed my problem.

Go to your usermod folder, backup your particles folder and delete it.

If you dont have a particles folder, you might be dealing with something else.
MLTDG 23 авг, 2013 @ 19:26 
I'll give that a try.

Update: I deleted my usermod\particles folder, like you suggested, and it worked!
Последний раз отредактировал MLTDG; 23 авг, 2013 @ 19:39
Показано 19 из 9 комментариев
< >
На страницу: 15 30 50
Дата создания: 31 июл, 2013 @ 13:23
Сообщений: 9