Source Filmmaker > Discussões Gerais > Detalhes do Tópico
MLTDG 31 Jul, 2013 às 13:23
Firing weapons crashes the program
Every time I enter game mode and try to fire ANY weapon, SFM completely locks up, then crashes. I've tried the obvious solutions (verifying my cache, launching SFM through SDK, etc.), but they didn't work. I want to know (a) what is causing this, and (b) how to fix it.
A mostrar 1-9 de 9 comentários
< >
PlayerZERO 31 Jul, 2013 às 13:34 
Does it happen w/ melee weapons, too?
MLTDG 31 Jul, 2013 às 14:51 
Originalmente postado por PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg 31 Jul, 2013 às 18:48 
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Última alteração por SamSpielberg; 31 Jul, 2013 às 18:48
PlayerZERO 31 Jul, 2013 às 18:50 
Originalmente postado por MLTDG:
Originalmente postado por PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
Originalmente postado por SamSpielberg:
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Actually, the red X thing happened to me before the update.
R234 31 Jul, 2013 às 18:54 
Have you tried restarting Steam since the update? I hear that sometimes works.
MLTDG 31 Jul, 2013 às 19:09 
Originalmente postado por R234:
Have you tried restarting Steam since the update? I hear that sometimes works.
That might work. I'll try it.
MLTDG 31 Jul, 2013 às 21:57 
I just restarted Steam, loaded the tf-movies "box" map, and attempted to fire Scout's scattergun. The program locked up for several minutes, THEN crashed--this time with an error message.

So, in other words, restarting Steam didn't help much, if at all.
THEYRE ALL DEAD!!!!!!!!!!!!!!!!! 23 Ago, 2013 às 15:33 
MLTDG, Try this, this fixed my problem.

Go to your usermod folder, backup your particles folder and delete it.

If you dont have a particles folder, you might be dealing with something else.
MLTDG 23 Ago, 2013 às 19:26 
I'll give that a try.

Update: I deleted my usermod\particles folder, like you suggested, and it worked!
Última alteração por MLTDG; 23 Ago, 2013 às 19:39
A mostrar 1-9 de 9 comentários
< >
Por página: 15 30 50
Postado a: 31 Jul, 2013 às 13:23
Comentários: 9