Source Filmmaker > 일반 토론 > 제목 정보
MLTDG 2013년 7월 31일 오후 1시 23분
Firing weapons crashes the program
Every time I enter game mode and try to fire ANY weapon, SFM completely locks up, then crashes. I've tried the obvious solutions (verifying my cache, launching SFM through SDK, etc.), but they didn't work. I want to know (a) what is causing this, and (b) how to fix it.
9개 중 1-9 표시중
< >
PlayerZERO 2013년 7월 31일 오후 1시 34분 
Does it happen w/ melee weapons, too?
MLTDG 2013년 7월 31일 오후 2시 51분 
PlayerZERO님이 먼저 게시:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg 2013년 7월 31일 오후 6시 48분 
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
SamSpielberg님이 마지막으로 수정; 2013년 7월 31일 오후 6시 48분
PlayerZERO 2013년 7월 31일 오후 6시 50분 
MLTDG님이 먼저 게시:
PlayerZERO님이 먼저 게시:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg님이 먼저 게시:
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Actually, the red X thing happened to me before the update.
R234 2013년 7월 31일 오후 6시 54분 
Have you tried restarting Steam since the update? I hear that sometimes works.
MLTDG 2013년 7월 31일 오후 7시 09분 
R234님이 먼저 게시:
Have you tried restarting Steam since the update? I hear that sometimes works.
That might work. I'll try it.
MLTDG 2013년 7월 31일 오후 9시 57분 
I just restarted Steam, loaded the tf-movies "box" map, and attempted to fire Scout's scattergun. The program locked up for several minutes, THEN crashed--this time with an error message.

So, in other words, restarting Steam didn't help much, if at all.
Honey Bunches of Swag 2013년 8월 23일 오후 3시 33분 
MLTDG, Try this, this fixed my problem.

Go to your usermod folder, backup your particles folder and delete it.

If you dont have a particles folder, you might be dealing with something else.
MLTDG 2013년 8월 23일 오후 7시 26분 
I'll give that a try.

Update: I deleted my usermod\particles folder, like you suggested, and it worked!
MLTDG님이 마지막으로 수정; 2013년 8월 23일 오후 7시 39분
9개 중 1-9 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 7월 31일 오후 1시 23분
게시글: 9