Source Filmmaker > Γενικές συζητήσεις > Λεπτομέρειες θέματος
MLTDG 31 Ιουλ, 2013 @ 1:23μμ
Firing weapons crashes the program
Every time I enter game mode and try to fire ANY weapon, SFM completely locks up, then crashes. I've tried the obvious solutions (verifying my cache, launching SFM through SDK, etc.), but they didn't work. I want to know (a) what is causing this, and (b) how to fix it.
Εμφάνιση 1-9 από 9 σχόλια
< >
PlayerZERO 31 Ιουλ, 2013 @ 1:34μμ 
Does it happen w/ melee weapons, too?
MLTDG 31 Ιουλ, 2013 @ 2:51μμ 
Αναρτήθηκε αρχικά από PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg 31 Ιουλ, 2013 @ 6:48μμ 
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Τελευταία επεξεργασία από SamSpielberg; 31 Ιουλ, 2013 @ 6:48μμ
PlayerZERO 31 Ιουλ, 2013 @ 6:50μμ 
Αναρτήθηκε αρχικά από MLTDG:
Αναρτήθηκε αρχικά από PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
Αναρτήθηκε αρχικά από SamSpielberg:
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Actually, the red X thing happened to me before the update.
R234 31 Ιουλ, 2013 @ 6:54μμ 
Have you tried restarting Steam since the update? I hear that sometimes works.
MLTDG 31 Ιουλ, 2013 @ 7:09μμ 
Αναρτήθηκε αρχικά από R234:
Have you tried restarting Steam since the update? I hear that sometimes works.
That might work. I'll try it.
MLTDG 31 Ιουλ, 2013 @ 9:57μμ 
I just restarted Steam, loaded the tf-movies "box" map, and attempted to fire Scout's scattergun. The program locked up for several minutes, THEN crashed--this time with an error message.

So, in other words, restarting Steam didn't help much, if at all.
Maize the Gardecunt 23 Αυγ, 2013 @ 3:33μμ 
MLTDG, Try this, this fixed my problem.

Go to your usermod folder, backup your particles folder and delete it.

If you dont have a particles folder, you might be dealing with something else.
MLTDG 23 Αυγ, 2013 @ 7:26μμ 
I'll give that a try.

Update: I deleted my usermod\particles folder, like you suggested, and it worked!
Τελευταία επεξεργασία από MLTDG; 23 Αυγ, 2013 @ 7:39μμ
Εμφάνιση 1-9 από 9 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 31 Ιουλ, 2013 @ 1:23μμ
Αναρτήσεις: 9