MLTDG Jul 31, 2013 @ 1:23pm
Firing weapons crashes the program
Every time I enter game mode and try to fire ANY weapon, SFM completely locks up, then crashes. I've tried the obvious solutions (verifying my cache, launching SFM through SDK, etc.), but they didn't work. I want to know (a) what is causing this, and (b) how to fix it.
Showing 1-9 of 9 comments
< >
PlayerZERO Jul 31, 2013 @ 1:34pm 
Does it happen w/ melee weapons, too?
MLTDG Jul 31, 2013 @ 2:51pm 
Originally posted by PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
SamSpielberg Jul 31, 2013 @ 6:48pm 
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Last edited by SamSpielberg; Jul 31, 2013 @ 6:48pm
PlayerZERO Jul 31, 2013 @ 6:50pm 
Originally posted by MLTDG:
Originally posted by PlayerZERO:
Does it happen w/ melee weapons, too?

I just checked. With melee weapons, it still crashes, but ONLY when I attempt to hit something that's part of the map (in my test, a wall). Swinging my weapon at the air doesn't cause any major problems.
Originally posted by SamSpielberg:
I've noticed since today's update that going in game in SFM and shooting around causes, for me, a missing particle effect which is a big explosion of red x's. Something appears to have been screwed in the update.
Actually, the red X thing happened to me before the update.
R234 Jul 31, 2013 @ 6:54pm 
Have you tried restarting Steam since the update? I hear that sometimes works.
MLTDG Jul 31, 2013 @ 7:09pm 
Originally posted by R234:
Have you tried restarting Steam since the update? I hear that sometimes works.
That might work. I'll try it.
MLTDG Jul 31, 2013 @ 9:57pm 
I just restarted Steam, loaded the tf-movies "box" map, and attempted to fire Scout's scattergun. The program locked up for several minutes, THEN crashed--this time with an error message.

So, in other words, restarting Steam didn't help much, if at all.
[PHX] Misaki Aug 23, 2013 @ 3:33pm 
MLTDG, Try this, this fixed my problem.

Go to your usermod folder, backup your particles folder and delete it.

If you dont have a particles folder, you might be dealing with something else.
MLTDG Aug 23, 2013 @ 7:26pm 
I'll give that a try.

Update: I deleted my usermod\particles folder, like you suggested, and it worked!
Last edited by MLTDG; Aug 23, 2013 @ 7:39pm
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Jul 31, 2013 @ 1:23pm
Posts: 9