Source Filmmaker

Source Filmmaker

Source Filmmaker > Dyskusje ogólne > Szczegóły tematu
Cake Face 28 lipca 2013 o 16:53
Compatibility with Animated Textures?
I've downloaded a few custom player models, 2 of which have heads that use an animated texture. But when I import these into SFM, the whole body shows up fine and everything, just the heads have the missing texture error.

I've tried messing around with the .vmt's trying to remove animated texture code, but no avail.

Here's the code for one of the animated texture's .vmt if anyone can spot an issue

"VertexLitGeneric" { "$baseTexture" "models\example\example_animation" "$bumpmap" "models\example\example_normal" "$envmap" "env_cubemap" "$envmapcontrast" "0.8" "$envmapsaturation" "[.5 .4 1.3]" "$envmaptint" "[.6 .6 .6]" "Proxies" { "AnimatedTexture" { "animatedtexturevar" "$basetexture" "animatedtextureframenumvar" "$frame" "animatedtextureframerate" "15" } } }
< >
Wyświetlanie 1-11 z 11 komentarzy
R234 28 lipca 2013 o 16:56 
What error message(s) do you get in the console when you load the model? That might tell us what's wrong.
Cake Face 28 lipca 2013 o 17:01 
** Error Unserializing VTF file... is the vtf file empty?
Error reading material data "models\example\example_animation.vtf"
Failed loading models/!

That's the only useful code I can find that might help explain the problem. It's strange, the vtf file isn't empty either and the model works perfectly in Garry's Mod.
R234 28 lipca 2013 o 17:06 
I've seen this numerous times. Sometimes textures will have to be opened and resaved to work in SFM. If you have VTFEdit or an image processing program with a VTF plugin you can do it yourself.
Cake Face 28 lipca 2013 o 17:15 
Well, I just tried to re-save the textures and what not. Still no avail. Am I suppose to be doing something different when saving the textures?
R234 28 lipca 2013 o 17:31 
Hm, not that I know of. Strange, it usually works...

Well, I dunno, do you think you could post the model and texture files somewhere so that I can have a look at them?
Cake Face 28 lipca 2013 o 17:46 
Well here are the ones that I'm mainly having trouble with. These come from the Garry's Mod workshop and are not mine.

Ostatnio edytowany przez: Cake Face; 29 lipca 2013 o 11:26
R234 28 lipca 2013 o 19:34 
I'll see if I can get this to work.


Resaving dafthelmet_animation.vtf and dafthelms_animation.vtf worked for me. I used GIMP with a VTF plugin, and exported with these settings:
If it really doesn't work on your end I can try to upload the ones I made somewhere.
Ostatnio edytowany przez: R234; 28 lipca 2013 o 20:01
Cake Face 28 lipca 2013 o 23:03 
Crap, no dice on my end. I've been trying the Photoshop and VTF Plugin with those settings and same thing.

If you can upload those somewhere, then thank you so much for your help.
Cake Face 29 lipca 2013 o 11:26 
Oh, well, after resaving the VTF as just a single frame texture and not a animation, I did get the models properly working. Just I had to sacrifce the animation aspect. Did you get the animations also working?
R234 29 lipca 2013 o 14:39 
Yes, the animations work. Here, see if these work:
Cake Face 30 lipca 2013 o 11:05 
Oh my god, these work! Thank you so much for your time! I just couldn't figure out what I was doing wrong, I even downloaded gimp and the .vtf file extension and it was doing the same thing. I heard SFM had issues with texture files over 10MB.
< >
Wyświetlanie 1-11 z 11 komentarzy
Na stronę: 15 30 50

Source Filmmaker > Dyskusje ogólne > Szczegóły tematu
Data napisania: 28 lipca 2013 o 16:53
Posty: 11