Source Filmmaker > 일반 토론 > 제목 정보
Vault Dweller 2013년 7월 27일 오후 6시 55분
Loose cannon being blue
When I load the loose cannon model and I move it around, it goes a very light blue. All of it. This is terribly annoying please help if possible.
4개 중 1-4 표시중
< >
A Socialist Pickle (Rodger) 2013년 7월 27일 오후 7시 50분 
I'm having the same problem with the medi-mask, exept it turns white (Which annoys the heck out of me, since it looks awesome when it's normal). I hope someone figures out this problem.
R234 2013년 7월 27일 오후 8시 48분 
The Loose Cannon uses shader code that isn't supported by SFM. I can't remember how I fixed it, but just replace the contents of game/tf/materials/models/weapons/c_items/c_demo_cannon.vmt with this:
"VertexlitGeneric"
{
"$baseTexture" "models\weapons\c_items/c_demo_cannon"
"$bumpmap" "models\effects\flat_normal"
"$basemapalphaphongmask" 1

"$phong" "1"
"$phongexponent" "10"
"$phongboost" "0.5"
"$lightwarptexture" "models\lightwarps\weapon_lightwarp"
"$phongfresnelranges" "[.55 .5 1]"

"$rimlight" "1"
"$rimlightexponent" "8"
"$rimlightboost" "1.5"

// "$detail" "effects/tiledfire/fireLayeredSlowTiled512"
// "$detailscale" "5"
// "$detailblendfactor" .01
// "$detailblendmode" 6

"$yellow" "0"

"$cloakPassEnabled" "1"

"Proxies"
{
"invis"
{
}

"AnimatedTexture"
{
"animatedtexturevar" "$detail"
"animatedtextureframenumvar" "$detailframe"
"animatedtextureframerate" 30
}

"BurnLevel"
{
"resultVar" "$detailblendfactor"
}

"YellowLevel"
{
"resultVar" "$yellow"
}

"Equals"
{
"srcVar1" "$yellow"
"resultVar" "$color2"
}
}}
In fact, if you were to check for the difference and tell us, that could be helpful :)
I suspect it has to do with them four commented out lines about detail texture...
A Socialist Pickle (Rodger) 2013년 7월 27일 오후 9시 36분 
Ah, thanks. I'm sure the thread author will appreciate this too. (And we all appreiciate the help you've provided to all people who use SFM!)
Vault Dweller 2013년 7월 27일 오후 10시 12분 
It works now! Thank you so very much! :D
I can't thank you enough. Thanks again!

Now to fix that missing texture in cp_lumberyard...
4개 중 1-4 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 7월 27일 오후 6시 55분
게시글: 4