Pass the Whiskey Jul 25, 2013 @ 5:20am
CSGO player models not showing in sfm
When I load the player models for Counter Strike: Global Offensive, all of them are invisible, they do not have a wire frame when I tick the option in the model viewer.

My process for importing these models is as follows:

1.Go to "Steam\steamapps\common\Counter-Strike Global Offensive\csgo"

2.Open pak01_dir with GFScape

3.Export to folder on desktop called: CSGO

4.Put the model_process batch file in and run it

5.After the procces is finished, move to "Steam\steamapps\common\SourceFilmmaker\game"

6. go to "Steam\steamapps\common\SourceFilmmaker\game\usermod" and add the appropriate lines to the "gameinfo" txt file.

7.Close and launch source filmmaker

After doing all of the above, the weapons and particles are showing, and also some of the props.

The invisible props are still listed in the model viewer, and they still have the bones and collision meshes, but they are completely invisible without the motion editor (only the bones are visible).

This only occured after I tried inserting CSGO maps into the folder, then deleting the folder from the directory, and redoing the process.
Showing 1-8 of 8 comments
< >
Pte Jack Jul 25, 2013 @ 10:52am 
Watch this, it should work for you

http://youtu.be/UP_QvuYJezU
Pass the Whiskey Jul 26, 2013 @ 4:05am 
Thank you for trying to help, but I have already fixed it. I appreciate you trying though
Herbert the Necron Lord Aug 12, 2013 @ 6:50pm 
I know it's been a while, but do you remember how you fixed it? I am having the exact same problem and if you do remember what you did to fix it I would like that information to solve my problem. Thanks in advance, whether you can or cannot help.
Pass the Whiskey Aug 15, 2013 @ 2:19am 
I completely redid the entire process above, I deleted all of the CS files, and redownloaded the batch file, If the batch file does not close automatically, try again with a fresh one. Then put the files in.

You might also want to check your "gameinfo.txt" to see if the line has been deleted or replaced for some unknown reason.

Download link(s) in the description of this video: http://www.youtube.com/watch?v=HUU1Cv8ibjI

Try multiple times, you might get lucky like I did.
Last edited by Pass the Whiskey; Aug 15, 2013 @ 2:24am
Herbert the Necron Lord Aug 15, 2013 @ 12:49pm 
Thanks. Worked quite nicely.
Pass the Whiskey Aug 16, 2013 @ 1:28am 
:)
LucasGodzilla Oct 27, 2013 @ 12:16pm 
Well question, I did the same you did (Deleted and re-extracted the models folder from my game) but I did it like 3 times and still not working!
Psi Oct 27, 2013 @ 12:33pm 
Originally posted by LucasGodzilla:
Well question, I did the same you did (Deleted and re-extracted the models folder from my game) but I did it like 3 times and still not working!

did you run the model_process batch thing in the folder again?

having this problem lately a lot. My models for CSGO and L4D2 keep going invisible on me. I don't understand it. This stuff never happens to me with custom models that i install, only full mounted game folders like CSGO and L4D2.
Last edited by Psi; Oct 29, 2013 @ 10:55am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jul 25, 2013 @ 5:20am
Posts: 8