Source Filmmaker > 一般的な話題 > トピックの詳細
ThatStupidSquid 2013年7月2日 5時45分
Rendered Videos Broken?
I can add costom models and folders without fail.
I can animate without fear of crashing.
I can(ish) use particles and lip-sync with no error.
I can render the work with ease and patence.

...But when I try to open the rendered video file in anything I own. It either only plays the audio, skips or freezes on frames for seconds, or says the file is not playable, or that the compression code is unknown, or just simply crashing.

I can render it as a TGA sequence but the time it takes to render is long and the quality suffers when I compile it into a AVI (it works then for some reason).

Anyone having this? Or fixing this? Or has fixed this?
1-10 / 10 のコメントを表示
< >
R234 2013年7月2日 16時47分 
That's because SFM made AVIs are massive and not meant to be read as is. You could export your video as a PNG image sequence with the sound and make a video out of it with VirtualDub and the h264 plugin for compression. That way you get a high quality compressed AVI that's not too heavy. My 10:45 720p 30 fps movie weighs only 246 megs, for instance.
Pte Jack 2013年7月2日 18時06分 
Yo could also download Quicktime and install it. This should give you the ability to render a MP4 file.
ThatStupidSquid 2013年7月2日 19時09分 
R234 の投稿を引用:
...You could export your video as a PNG image sequence with the sound and make a video out of it with VirtualDub...

I've been doing that... I just thought there might be a simpler way. Anyway, back to animating!

Pte Jack の投稿を引用:
Yo could also download Quicktime and install it. This should give you the ability to render a MP4 file.

It does... but still nothing can read it but quicktime while loading only half the video before the frames freeze up.
Pte Jack 2013年7月2日 19時20分 
MP4 format is readable by most video programs. It is one of the most portable formats out there, PC, Table, Smartphone, etc. I create mp4s on my system and play them in VLC, Window Media Player and can even edit them in Windows Moviemaker or other 3rd party editing software if I wanted to.

You might check your other compression settings if you are having problems opening MP4 files... Try this format MP4, MPEG, No Gama Adjust.
ThatStupidSquid 2013年7月2日 19時26分 
I render uncompressed... and everything goes nuts as I said.

... I'll try compressing next time. Or just do the .tga to .avi thing i've been doing with Virtualdub.

Thanks for the kind enhancement of knowledge in virtual animation rendering.
KoeWaffle 2013年7月3日 4時32分 
I render every shot seperately, this way Sony Vegas has no problems with it. Uncompressed AVI style of course. Since shots aren't that long (~15 seconds is fine) it works perfectly for me.
Blake Belladonna+Yang Xiao Long 9月10日 11時42分 
I also have this weird render issue. I have rendered another project just fine uncompressed. I tried to make another project and render and sometimes my comp needs to restart/crash, or that does not happen but the file is completely messed up.

Here is desktop footage.
https://drive.google.com/file/d/0Byki_SyKYUMCV2tsdnRKNU1rcjQ/edit?usp=sharing
最近の変更はBlake Belladonna+Yang Xiao Longが行いました; 9月10日 11時42分
Pte Jack 9月10日 13時22分 
Ah yes, the old "trying to render an avi file" bug... Most ppl now either render in mp4 (with quicktime installed) or do image sequences and process the images and audio through virtual dub. AVI is usually buggy at the best of times.
Blake Belladonna+Yang Xiao Long 9月10日 15時16分 
Pte Jack の投稿を引用:
Ah yes, the old "trying to render an avi file" bug... Most ppl now either render in mp4 (with quicktime installed) or do image sequences and process the images and audio through virtual dub. AVI is usually buggy at the best of times.

Appreciate the timely reply, going to go install quicktime now.
最近の変更はBlake Belladonna+Yang Xiao Longが行いました; 9月10日 15時16分
Pte Jack 9月10日 15時59分 
Don't forget to reboot the computer after the quicktime install, or SFM won't register the codec for it.
1-10 / 10 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年7月2日 5時45分
投稿数: 10