Source Filmmaker > 综合讨论 > 主题详情
O'Nyxon McRunner 2013年6月25日下午3:39
Zombie skin problem
Then i select zombie skin on tf2 player model, whole body is transperent except for a head. Any ways of how to fix it?
正在显示第 1 - 15 条,共 19 条留言
< >
Pte Jack is away for a MONTH 2013年6月25日下午3:41 
We're still digging it to that and haven't found the magic phrase to make them whole. But,

http://youtu.be/64lKrw7hRgw
O'Nyxon McRunner 2013年6月25日下午3:50 
I am not talking about this kind of thing. I know how to add missing body parts, i am talking about this: http://img706.imageshack.us/img706/6614/4rwi.png
最后由 O'Nyxon McRunner 编辑于; 2013年6月25日下午3:51
Pte Jack is away for a MONTH 2013年6月25日下午3:53 
Yup, and that's what I said, we haven't found the shader that is causing this yet, we're still looking for the magic phrase to make it solid... Try turning off AO for now (haven't tried this yet myself, but it does work on some models)...
Pte Jack is away for a MONTH 2013年6月25日下午4:01 
Yup, turning AO off will make him solid, but no AO.

http://imgur.com/XExqAxC
最后由 Pte Jack is away for a MONTH 编辑于; 2013年6月25日下午4:04
R234 2013年6月25日下午4:29 
You can also make the texture not render AO, by typing the following line of code in the appropriate material (.vmt) file:
"$ambientocclusion" "0"
That way you can have AO on models that allow for it, while disabling the so-called "see-through" AO on translucent textures.
Pte Jack is away for a MONTH 2013年6月25日下午4:31 
Just tried that R234, on the demoman_red_zombie.vmt file... does not work, tried 1 and 0. I think you have to find every associated vmt and turn it off in all of them to make it work. Looking for them now.
R234 2013年6月25日下午4:44 
You have to put it into demoman_red_zombie_alphatest.vmt too, apparently.
R234 2013年6月25日下午4:56 
There's an other way, too. You can disable (by commenting it out) "alphatest" "1" in demoman_red_zombie_alphatest.vmt. This will make ambient occlusion work on the model. The downside is that it will disable transparency on the texture, rendering it impossible to use the zombie misc (exposed bones and all that) with it, so they won't look like in TF2. Example shots:
http://i.imgur.com/6WYqjUi.jpg
Furious Potato 1月5日上午10:48 
You can decompile the model, add $mostlyopaque to the QC file and recompile. Is a long process but it solves the problem without disable AO
Cartré the Almighty 2月17日下午12:57 
Disabling Ambient Occlusion fixed it for me.
Pte Jack is away for a MONTH 2月17日下午1:14 
yeah, but that kills AO in your render as well. Find the zombie vmts with the "$alphatest" "1" in them and add the command $mostlyopaque below it.

http://youtu.be/EywdZE2H4Nk
Furious Potato 4月1日上午7:08 
Well, sorry but I add the "$mostlyopaque" "1" and there's no change. Any ideas?
Pte Jack is away for a MONTH 4月1日下午1:44 
No, actually I don't...

Other ppl have reported that it doesn't work for them as well.

The $mostlyopaque command is usually a qc type command, added to the qc when compiling a model. I've tried it on a few model vmts were I run into the grainy transparency problem now, one being the degreaser, and it seems to work for me on the models I've tried.

I'm starting to wonder if it might be something that triggers a setting on my GPU to render correctly when it encounters the command, but I doubt it.

But that being said, All my GPU are radeon HD Series Card and chips.
最后由 Pte Jack is away for a MONTH 编辑于; 4月2日上午8:05
Furious Potato 4月2日上午7:28 
Well, where do you put the "$mostlyopaque" "1" to fix the transparency problem?
Pte Jack is away for a MONTH 4月2日上午9:12 
Ah man, you had to ask... That was a couple of months and 6 reinstalls of SFM ago... And I answered you in a chat session... The one were in now.... lol
正在显示第 1 - 15 条,共 19 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年6月25日下午3:39
帖子数: 19