Source Filmmaker

Source Filmmaker

Source Filmmaker > Algemene discussies > Details van topic
O'Nyx Mayfield 25 jun 2013 om 3:39nm
Zombie skin problem
Then i select zombie skin on tf2 player model, whole body is transperent except for a head. Any ways of how to fix it?
< >
1-15 van 19 reacties weergegeven
Pte Jack AFK 25 jun 2013 om 3:41nm 
We're still digging it to that and haven't found the magic phrase to make them whole. But,

http://youtu.be/64lKrw7hRgw
O'Nyx Mayfield 25 jun 2013 om 3:50nm 
I am not talking about this kind of thing. I know how to add missing body parts, i am talking about this: http://img706.imageshack.us/img706/6614/4rwi.png
Laatst bewerkt door O'Nyx Mayfield; 25 jun 2013 om 3:51nm
Pte Jack AFK 25 jun 2013 om 3:53nm 
Yup, and that's what I said, we haven't found the shader that is causing this yet, we're still looking for the magic phrase to make it solid... Try turning off AO for now (haven't tried this yet myself, but it does work on some models)...
Pte Jack AFK 25 jun 2013 om 4:01nm 
Yup, turning AO off will make him solid, but no AO.

http://imgur.com/XExqAxC
Laatst bewerkt door Pte Jack AFK; 25 jun 2013 om 4:04nm
R234 25 jun 2013 om 4:29nm 
You can also make the texture not render AO, by typing the following line of code in the appropriate material (.vmt) file:
"$ambientocclusion" "0"
That way you can have AO on models that allow for it, while disabling the so-called "see-through" AO on translucent textures.
Pte Jack AFK 25 jun 2013 om 4:31nm 
Just tried that R234, on the demoman_red_zombie.vmt file... does not work, tried 1 and 0. I think you have to find every associated vmt and turn it off in all of them to make it work. Looking for them now.
R234 25 jun 2013 om 4:44nm 
You have to put it into demoman_red_zombie_alphatest.vmt too, apparently.
R234 25 jun 2013 om 4:56nm 
There's an other way, too. You can disable (by commenting it out) "alphatest" "1" in demoman_red_zombie_alphatest.vmt. This will make ambient occlusion work on the model. The downside is that it will disable transparency on the texture, rendering it impossible to use the zombie misc (exposed bones and all that) with it, so they won't look like in TF2. Example shots:
http://i.imgur.com/6WYqjUi.jpg
Xpanix 5 jan 2014 om 10:48vm 
You can decompile the model, add $mostlyopaque to the QC file and recompile. Is a long process but it solves the problem without disable AO
Beesore the Attention Whore 17 feb 2014 om 12:57nm 
Disabling Ambient Occlusion fixed it for me.
Pte Jack AFK 17 feb 2014 om 1:14nm 
yeah, but that kills AO in your render as well. Find the zombie vmts with the "$alphatest" "1" in them and add the command $mostlyopaque below it.

http://youtu.be/EywdZE2H4Nk
Xpanix 1 apr 2014 om 7:08vm 
Well, sorry but I add the "$mostlyopaque" "1" and there's no change. Any ideas?
Pte Jack AFK 1 apr 2014 om 1:44nm 
No, actually I don't...

Other ppl have reported that it doesn't work for them as well.

The $mostlyopaque command is usually a qc type command, added to the qc when compiling a model. I've tried it on a few model vmts were I run into the grainy transparency problem now, one being the degreaser, and it seems to work for me on the models I've tried.

I'm starting to wonder if it might be something that triggers a setting on my GPU to render correctly when it encounters the command, but I doubt it.

But that being said, All my GPU are radeon HD Series Card and chips.
Laatst bewerkt door Pte Jack AFK; 2 apr 2014 om 8:05vm
Xpanix 2 apr 2014 om 7:28vm 
Well, where do you put the "$mostlyopaque" "1" to fix the transparency problem?
Pte Jack AFK 2 apr 2014 om 9:12vm 
Ah man, you had to ask... That was a couple of months and 6 reinstalls of SFM ago... And I answered you in a chat session... The one were in now.... lol
< >
1-15 van 19 reacties weergegeven
Per pagina: 15 30 50

Source Filmmaker > Algemene discussies > Details van topic
Geplaatst op: 25 jun 2013 om 3:39nm
Aantal berichten: 19