[NoU] Ghift 12. Feb. 2013 um 14:16 Uhr
Basic Camera Controls Aren't Working
All of a sudden (possibly caused by the last update? I hadn't used SFM in a while before this but it HAS worked in the past on this computer) I can't move the camera. At all. The best I can do is spin in a circle with the mouse but WASD just aren't working at all for me regarding the camera and I've tried all the basic stuff including reinstalling the whole thing.

Maybe I'm missing something really dumb but I can't do anything until I figure this out.
Beiträge 1 - 9 von 9
< >
Sneaky 12. Feb. 2013 um 14:28 Uhr 
Do you have a camera element at all in the list of models loaded into whatever scene you are in? (animation set editor) if so, you need to make sure you highlight by left clicking on it and then motion editor to WASD move it around. that is the only thing that springs to mind why you cannot move it right away if not that then post back and I will try to think of something else.
Zuletzt bearbeitet von Sneaky; 12. Feb. 2013 um 14:30 Uhr
[NoU] Ghift 12. Feb. 2013 um 15:39 Uhr 
I've tried doing it with and without a camera element, on the work camera and a numbered camera, nothing seems to work. I'll try what you've said when I get the chance, though.

At this point I'm just loading in a map and can't move from the spawn point at all, I can just spin in a circle regardless of what I try.

WASD works if I go in-game, it's just like the camera refuses to move from the spot.
Zuletzt bearbeitet von [NoU] Ghift; 12. Feb. 2013 um 15:39 Uhr
Sneaky 12. Feb. 2013 um 15:54 Uhr 
The only other thing I can think of is not holding left click on the view port and then WASD with it held down, just shooting ideas to help solve it I have alot of times tried to move the camera in the viewport or work cam without pressing and holding left click on it.
Zuletzt bearbeitet von Sneaky; 12. Feb. 2013 um 15:54 Uhr
Pte Jack 12. Feb. 2013 um 16:18 Uhr 
Ghift,

Revalidate the cache files, if you haven't used it in a while, there have been a slew of updates.

Steam Client, Library, All Software, Right Click Source Filmmaker
Properties, Local Files, Verify integrity of Application Cache.

[NoU] Ghift 12. Feb. 2013 um 17:09 Uhr 
Ursprünglich geschrieben von Pte Jack:
Ghift,

Revalidate the cache files, if you haven't used it in a while, there have been a slew of updates.

Steam Client, Library, All Software, Right Click Source Filmmaker
Properties, Local Files, Verify integrity of Application Cache.

I deleted the whole thing and reinstalled it, didn't work.



Ursprünglich geschrieben von Sneaky:
The only other thing I can think of is not holding left click on the view port and then WASD with it held down, just shooting ideas to help solve it I have alot of times tried to move the camera in the viewport or work cam without pressing and holding left click on it.

I'll mess about a bit more with it when I wake up, I beleive I've tried that but it won't hurt to try again.
[NoU] Ghift 12. Feb. 2013 um 18:18 Uhr 
I tried hitting alt+w with a camera asset/motion graph - the camera flew off into the sunset in the direction I faced every time I clicked on it, ctrl worked to slow it down. WASD still doesn't work however I have found a workaround with the alt controls as long as I don't hit W, haha.

I'll try validating the files on top of the reinstall. The only thing I can think of at this point is some kind of control mess up? Though I might be talking ♥♥♥♥♥♥♥♥ and clutching at straws.
Zuletzt bearbeitet von [NoU] Ghift; 12. Feb. 2013 um 18:18 Uhr
Pte Jack 12. Feb. 2013 um 19:00 Uhr 
check your keyboard shortcuts you may have reassigned the move keys somehow... in SFM Windows -> Keyboard Shortcuts.
juen 28. März um 14:31 Uhr 
I was having the same problem. What I did was in camera 1 (or whatever camera isnt working), select the down arrow by the camera selection, and select "Select animation sets".

Hope that helped.
Cheyenne Dayrider 21. Dez. um 11:30 Uhr 
I have a problem like this, only when I try and add another camera movement after setting the first bookmark, the camera won't move at all, no spinning no WASD keys either, it's like locked in place.
Beiträge 1 - 9 von 9
< >
Pro Seite: 15 30 50