Shades Feb 10, 2013 @ 1:11am
Flickering in the Primary viewport and a loss of movement...
I had this problem with SFM that would flicker with what appears to be the old menu, or something, If I were to move the camera in a constant direction I would see it flicker so much that it would stop the movement of the camera unless I move in a different direction (I'm basicly spamming A and D when I move). Also, I don't know what update it was since the flickering discouraged me to use SFM for a while, but when I move a limb on a model, or when I move a model at all, The view port will not show me the movement untill I release my primary mouse key. Can some one please tell me what I can do?

I have Intel core i7-2670QM CPU @2.20 GHZ
Memory of 8 GB
Hard Drive of 1 TB
Showing 1-8 of 8 comments
< >
Pte Jack is away for a MONTH++ Feb 11, 2013 @ 7:10am 
Graphics card and are you on a laptop?
Shades Feb 11, 2013 @ 7:27am 
Originally posted by Pte Jack:
Graphics card and are you on a laptop?
Nvidia, Geforce 700M, and yes I am. Is there a problem with SFM on a laptop?
Pte Jack is away for a MONTH++ Feb 11, 2013 @ 8:41am 
SFM doesn't like laptops very much, a chipset is not the same as a full blown graphics card. According to the sites I've visited while looking up your chip, it would appear that the 700M is a rebadged 600 series chip.
Read this

http://www.anandtech.com/show/6579/nvidias-annual-gpu-rebadge-begins-geforce-gt-730m-and-geforce-710m-partial-specs-published and

http://www.game-debate.com/hardware/index.php?gid=1250&graphics=GeForce 710M#performance2value

But that being said your CPU, Ram and Graphics should be enough to support SFM. The fact that SFM loads at all proves that.

The reason for the jerkiness MAY BE due to the amount of load on your laptop. Laptops require a lot more drivers and other services in order to operate. That's where I'd start looking. What do I need to operate the laptop and what can I turn off when running SFM. Turning off services and background programs might help with SFM performance. You're pretty much stuck with the components that are embedded in the laptop, so component upgrades are not an option.

Other than that, move to a desktop...
Shades Feb 11, 2013 @ 9:24am 
Originally posted by Pte Jack:

Other than that, move to a desktop...
Well thanks for your time, guess I'll have to start to invest I guess...
Pte Jack is away for a MONTH++ Feb 12, 2013 @ 6:36am 
Here's another thing you can try, read this discussion...

http://steamcommunity.com/workshop/discussions/-1/864958451717811593/?appid=1840
Flowey the Flower...? Feb 14, 2013 @ 12:01am 
I've got a similiar problem. Laptop with Nvidia Geforce 500M or something, 64x system windows 7, 8Gig Ram and dual core 3.0 Gigahertz max.
After a little tinkering, I've found out that turning off the Nvidia card and making it run off the main GPU makes it work perfectly, however it'll give some message about it not being able to run some Model Processor 3.0 or something, plus I'm pretty sure the lighting processing is mostly scrapped.
I recommend you go into your Nvidia settings and set it to run SFM on the main GPU for now, it should make SFM run without the flickering nonsense, even if it causes one or two slight annoyances. This will make it less annoying until Valve releases a proper patch or someone makes a proper fix.
Plus, I've found out that this screen it flickers to is the Game engine screen. If you go into some option or other and turn off the Game engine's auto-hide, you'll get a good look at it. Doesn't make it any less infuriating, though...
Fred (Recerlo) Jun 18 @ 12:15am 
My problem is similar but i'm on a desktop it just happened today and includes the menu where i try to load models please help

AMD Athlon(tm)II X2 270 Processor 3.40GHz
8gb Ram
64 Bit OS Windows 7 Home Premium
ATI Radeon HD 5700 Series
2spooky4u Jul 28 @ 3:41am 
Originally posted by Flowey the Flower...?:
I've got a similiar problem. Laptop with Nvidia Geforce 500M or something, 64x system windows 7, 8Gig Ram and dual core 3.0 Gigahertz max.
After a little tinkering, I've found out that turning off the Nvidia card and making it run off the main GPU makes it work perfectly, however it'll give some message about it not being able to run some Model Processor 3.0 or something, plus I'm pretty sure the lighting processing is mostly scrapped.
I recommend you go into your Nvidia settings and set it to run SFM on the main GPU for now, it should make SFM run without the flickering nonsense, even if it causes one or two slight annoyances. This will make it less annoying until Valve releases a proper patch or someone makes a proper fix.
Plus, I've found out that this screen it flickers to is the Game engine screen. If you go into some option or other and turn off the Game engine's auto-hide, you'll get a good look at it. Doesn't make it any less infuriating, though...

How do i switch to GPU ?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50