Mixton May 19, 2013 @ 3:42am
Problem with exporting posters
I'm trying to create a poster from an animation I finished. However, whenever I try to select Export > Poster, choose the settings and select export, nothing happens. The export poster progress bar doesn't show up and the playhead moves to the beginning of the clip for some reason.

SFM doesn't doesn't freeze or anything after this, however when I drag the playhead through the clip, the viewport only displays the one frame I wanted a poster of.

I've tried it with other movies and have created a test poster from scratch and the same thing happens. Any help would be appreciated.
Last edited by Mixton; May 19, 2013 @ 3:43am
Showing 1-8 of 8 comments
< >
HerreH May 19, 2013 @ 4:03am 
I figured out how to export it to an image, but I have the same problem when I try to actually post it to the Steam Community site. If you just want the image to appear on your PC just for you to access I could help you.
I'm looking for a way to get the posters to appear in Steam too.
Mixton May 19, 2013 @ 4:26am 
I was planning on uploading the image to an image hosting website, however I hadn't considered the Steam Community site. For now, just being able to get the poster to export would be a step in the right direction. This is the first time I've tried creating a poster, so I imagine I've messed up somewhere.
HerreH May 19, 2013 @ 4:42am 
The way I export my posters to my PC is the following:
- Give SFM the Launch property: -sfm_resolution 1080
Exporting it without doing this caused my poster to have a weird line through the poster, no idea what caused it though.
- In SFM, just make a screenshot with F12. This screenshot will be a placeholder for your image.
- Now, go to File and Export and save the image as a .jpeg file
- Don't just save the image anywhere, go to your SFM screenshots map (on my PC it is located in: (...\Steam\userdata\56698564\760\remote\1840\screenshots) and save the image as the placeholder screenshot you just made. SFM will now export and if I told you everything correctly (not 100% sure about that myself) you should have an 1080p image located in that map now.
I hope this helps.
Mixton May 19, 2013 @ 5:39am 
Thanks for the response! I followed the instructions and was able to export it as an image. Odd that the export poster doesn't seem to work the same way. Either way, thanks for the help.
HerreH May 19, 2013 @ 5:55am 
No problem, glad to help :) And yeah I'm still wondering wether I'm doing something wrong or SFM needs to be fixed too. I guess we'll see in time.
Pte Jack May 19, 2013 @ 9:33am 
No, this has been a problem since day one...

For some reason or other I can't save a screenshot using F12 anymore, but this was a tut I did when I could...

http://youtu.be/bydlmLRO7A4
Doc Brown Jun 27 @ 4:38pm 
I can't save a screenshot with f12 for some reason, it just won't work.
How do I fix this?
Pte Jack Jun 27 @ 4:40pm 
Obviously did not read my post above...
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: May 19, 2013 @ 3:42am
Posts: 8