Source Filmmaker

Source Filmmaker

Camera glitch out - scoured the internet, cannot find fix.
As I go through the map with the work, or any, camera, it speeds up considerably at random intervals, skipping through and giving me a very shaky, jumping recording. I've turned off Progressive Refinement, but cannot find a solution to the breaking camera - does anybody have one? I fixed it in Beta, but haven't touched SFM since yesterday since then.
< >
Beiträge 115 von 17
Pte Jack 1. Mai 2013 um 9:04 Uhr 
Have you checked your graph editor, Have you accidentally input keyframes some how at the points the camera seems to glitch out? Are the curves smooth?
Zuletzt bearbeitet von Pte Jack; 1. Mai 2013 um 9:05 Uhr
R234 1. Mai 2013 um 12:51 Uhr 
To whoever it is that keep telling people to disable progressive refinements: stop it. Progressive refinements has no bearing on framerate or stability. Only ambient occlusion does.

As for your problem, I'd recommend not puppeteering camera movements, animate it manually in the motion/graph editor instead.
I haven't touched the graph editor, and I'm not puppeteering the movements (intentionall, anyway)((unless you mean just right clicking, holding it down, and using WASD for flying camera mopvement)) - this is before anything, before I've even set a model, as soon as I load the map and fly around in the Work Camera, it's very jumpy and seems like it skips, but the timeline remains fluid. My system specs are above par. I will have to animate the camera models directly, so thank you for that bit of input. Unfortunate, but it'll have to do.
Zuletzt bearbeitet von 🌊TeamSweaty.Alexis🌊; 1. Mai 2013 um 15:33 Uhr
Pte Jack 1. Mai 2013 um 16:35 Uhr 
So this is NOT an animated camera then, you're just flying it around and you're seeing the jerkiness.
As R234 says, you can turn the progressive refinement back on, it has no bearing, but I have to ask, what type of Vid card do you have? AMD Radeon or Intel Nvidia or somethings again? If Nvidia I would suggest turning off AO (Ambient Occlussion) to see if that helps your situation.

Also, you wouldn't happen to be pressing the Shift or Control key while flying around?
Pressing Shift while flying the camera will speed up the transition and control will slow down the transition (or the other way round, but I think I'm right).

I believe puppetteering the camera means either locking the camera to a bone and recording the action as the locked item moves or pressing play and record the scene by flying the camera around, (@ R234 would you explain what you mean by this??? I'm confused?? Thanks).
R234 1. Mai 2013 um 17:46 Uhr 
Puppeteering is when you apply movement manually to an animation set while the scene is playing, i.e. pressing space then moving the camera around with the mouse to record its movement. It's a useful technique to add noise in a camera's movement for instance, though since it uses raw mouse input it's best to smooth it out quite a bit as it can be a bit jerky. For the most part though cameras should be animated with the usual falloff regions method, or the graph editor.

Official tutorial #7 explains it at about 2:50, using as an example rotation of a Pyro's head:
Pte Jack 1. Mai 2013 um 19:26 Uhr 
Ah, ok, I was on the right track with my explanation (well the last half anyway). lol

Thought I was losing it for a minute...
No, no, I used the Beta and I've made a couple of short films, I'm not hitting Shift or any of the more basic issues that would arise with something like this, but I appreciate covering all the grounds. I am using an AMD Radeon 4600. I'm not looking to use the camera as a shot camera, it's just annoying to be working with the Work Camera and have it skip around so often, and it's tedious to have to press Ctrl to keep it from skipping, it does so often anyway. I will try to turn off AO but I've changed all settings, even the in-game ones, and nothing budges for me.
Pte Jack 1. Mai 2013 um 22:12 Uhr 
If you've changed a lot of stuff, then I would suggest doing a revalidation of your cache files or maybe try (In SFM) Help - Reset Setting. Maybe that might calm down the camera a bit. I think I saw something on this in an ealier post as well. Try a search in the discussion group. Can't narrow the parameters down for you but "jerky camera" might work.
Zuletzt bearbeitet von Pte Jack; 1. Mai 2013 um 22:18 Uhr
Thank you. Jerky was an adjective I hadn't tried. I will make a new post should the problem persist, but I'm getting along okay without it. Thank you two for your extended help! :D
Pte Jack 2. Mai 2013 um 8:29 Uhr 
I found the post I was thinking of, (round the 13th of March) but there were no answer to it and I don't know if the person was able to fix it. Sorry...
Pte Jack 2. Mai 2013 um 8:55 Uhr 
I'm quite sure you have done this already but make sure you have the most current drivers for your card. Unfortunately I pulled my 4600 series card and replaced it with a 5000 series card a little while ago, so I can't try to dupe your problem with one of my machines, but the 4000 series should be able to run SFM without problems. Go into the Catalyst Control Centre and check that your 3D option is set to default settings (ie let the Application control the card)

One last stupid question to you (and the reason I say stupid is because I'm quite sure you've done this and it is stupid on my part to ask but it never hurts to check) is Go to Windows, Engine Window, is Auto Hide Engine Window checked on?

Sorry grasping at straws here, as I said, you should have no problem running SFM on that card.

(I maintain that the only stupid question is the one that isn't asked!!)
Cap Cube 7. Juli 2013 um 12:59 Uhr 
I have the same problem.only it's with all cameras.tried everything on this thread and it still is hmm............... a wobbly as a 50ton elephant on a small unicycle.(understatement actually)
any ideas?
my computer is NOT new,is it even worth trying to make SFM movies or should I just forget about it till I get a new one?
Zuletzt bearbeitet von Cap Cube; 7. Juli 2013 um 13:01 Uhr
Yeen-Bean 4. Nov. 2014 um 13:00 Uhr 
I hate that this post is so old yet has the most comments, even then, nobody has offered ANYTHING helpful, none of the suggestions work. This is still a valid and painful problem, it's a shame it hasnt been fixed.
Pte Jack 4. Nov. 2014 um 14:31 Uhr 
The reason why is that either we don't have an answer or that suggestions given have been tried and fixed the problem. This could very well be an individual's computer graphic card setup problem. A lot of us can't duplicate or it hasn't happened to us. We can't fix something that is user based or can't be replicated.
Pte Jack actually did a very good solution. Update all drivers and reinstall. Delete ALL cache files. Basically, format your computer if you want to use SFM. But truth be told, it's a small glitch that if you're determined, it's easy to get past.
< >
Beiträge 115 von 17
Pro Seite: 15 30 50

Geschrieben am: 1. Mai 2013 um 0:55 Uhr
Beiträge: 17