Source Filmmaker > 综合讨论 > 主题详情
Haylex 2013年4月19日下午8:00
[SOLVED] Low FPS on New Gaming Computer
Hey everyone. I know this has been posted so many times before (I've done A LOT of Googling around), but I really have no clue how to fix this.

When I first start SFM, I get 5 fps when looking around the map (at low TF2 graphics settings). I have tried turing off Ambient Occlusion, Progressive Refinement, and Lighting, but that only increased the fps to 9-10. I've tried upping the priority in Task Manager, to no effect.

I have a very new gaming computer (got it a few days ago).
Specs:
Intel Core i7-3630QM
Nvidia GeForce GTX 675M / 2GB
DDRIII 12GB RAM

Upon running Dxdiag the display device used to say "Intel HD graphics," but after I disabled integrated graphics it says "Microsoft Basic Display Driver." I don't know why it's not recognizing my GeForce, but SFM didn't show up any errors.

I've tried everything people have posted on this forum, to no avail.
Any help is appreciated.
Thanks, Haylex.
最后由 Haylex 编辑于; 2013年4月20日上午10:08
正在显示第 1 - 5 条,共 5 条留言
< >
Pte Jack 2013年4月19日下午8:57 
Sorry, I have to defer the Nvidia questions, I don't know the cards... But, I think I saw something in another topic here in the discussion group about the auto detect mode not working with SFM and something about having to set the card up manually. Just do a search on the discussion group here you should find the post...
RoboticZombie1 2013年4月20日上午6:51 
Do any of your other games recognize the Nvidea card? Or do they also get really low fps? If your other games have this problem it could be that your drivers aren't up to date. Here's a link to test that if you haven't already. http://www.nvidia.com/Download/index.aspx?lang=en-us
Haylex 2013年4月20日上午10:08 
I believe I have figured it out! I accidently screwed up the computer messing with drivers, so starting from factory data, I did a clean install of the Nvidia driver (do NOT install the drivers that came with the computer). Then, in Nvidia Control Panel, I changed SFM to run with the GPU (as I did before), but this time I changed it to run with "Compatibiliy Performance."

I also disabled Secure Boot, if that does anything.

Now SFM runs at a smooth 30 fps :D
Thanks for your help!
xSniperKillingx 2013年4月22日下午6:02 
you!! save my life:D thanks!!!
Sztywniak 2013年8月28日上午4:36 
Dude i have problem. How do you change sfm in nivida control panel. I dont see anything like this
正在显示第 1 - 5 条,共 5 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年4月19日下午8:00
帖子数: 5