Dr John Healsgood Mar 18, 2013 @ 11:05am
SFM Keeps Crashing After Validating
I had a frequent error that occurred on startup for me (I'm sure some of you had this happen to you): "The program can't start because tier0_s.dll is missing" It didn't really stopped me from making videos, but it really bothered me.

I started verifying integrity of my steam cache for SFM, and apparently it said I was missing about 200mbs worth of files on my program. After it finished downloading, my current projects crash silently to desktop the moment I click on the video track, or transition to another clip.

I tried backing them up, but that didn't work. I'm contemplating reinstalling it, but I fear nothing will change, except I'll just be missing my usermod models and props.

As far as I've seen, it only occurs on saves, but not on new projects. Does anyone have a suggestion they could pitch? I'd very much appreciate it. I'd hate to start from scratch, I had a lot of projects.
Showing 1-6 of 6 comments
< >
Dr John Healsgood Mar 18, 2013 @ 11:10am 
PS: I'm hoping to document any changes I've done to SFM in the hopes that if I do get anything fixed. Anyone who had the same problem can learn from my mistakes.
Pte Jack is away for a MONTH++ Mar 18, 2013 @ 2:59pm 
The only thing I had to do when this tier0 error appeared for me was close and restart the Steam Client. The error went away. None of my projects were affected in the way you're suggesting. SFM booted properly and all my projects ran normally.
Dr John Healsgood Mar 18, 2013 @ 3:30pm 
@Pte Jack
Yeah, normally, I wasn't bothered by it, but then I validated my SFM cache, and it seemed to recovered some files that appeared to have been missing from my SFM. And now that SFM has been validated, the SFM projects that I have made during the time the Tier0 error occurred seems to be crashing now. Now I can't click on the video track without it crashing.
Pte Jack is away for a MONTH++ Mar 18, 2013 @ 4:50pm 
Have you tried going back to a previous version of SFM?

Library, All Softwares, Right click Source Filmmaker, Properties, Updates, Change Automatic Updates to Do not Automatically update this application
Click on Betas, and select Previous - Previous vesion or go all the way back by selecting 0.9.5.17
Launch SFM after the update and try your sessions.

If that doesn't work then I would suggest a complete uninstall and reinstall, as for your usermod stuff, pull the custom content stuff out and put it in a temporary folder, move it back after the reinstall. Do the same for your elements folder, That's where your sessions and renders are stored. If you have screenshot or screencasts or additional scripts, put them away in your temporay folder as well. Make a backup copy of your gameinfo.txt file and store that too.

You probably know this stuff already, but I need the typing practice.

Uninstall properly... Do the right click on SFM in your All Softwares library select properties then local files in the popup browser and delete the local cache. When complete, go in and check the SFM folder for anything left over that you might want to keep (there shouldn't be much), move that to the temp folder then delete the SFM folder completely...

Reinstall.

Load up a session that currently crashes SFM and see if it crashes.
Dr John Healsgood Mar 18, 2013 @ 4:57pm 
@Pte Jack
Thank you very much for the suggestions. It gives me some semblance of hope. I want to do a complete uninstall as a last resort, but your suggestion to revert to a previous version seems very plausible at this point.
Pte Jack is away for a MONTH++ Mar 18, 2013 @ 6:50pm 
Glad I could (ummm) sort of help, let me know what happens
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Mar 18, 2013 @ 11:05am
Posts: 6