UniverseBear Oct 26, 2013 @ 6:59pm
Maps won't load.
So I downloaded SFM, and I watched all the tutorials on Youtube. But I'm having a problem just simply loading maps. I open up the program, start a new project and then it gives me a nice clean project with no map loaded. I go to load a map, it doesn't matter which one I pick, and when it's done loaded the viewport just stays black. You can't see the map no matter what you do. The only way to see it is to go into that function where you can run around the map like it's in game. Otherwise it's completely black. The same thing happens if I try to load a pre-made project, like Meet the heavy. The viewport just stays black. I'd appreciate any help or ideas you guys have as I want to start learning this program as fast as I can to get some ideas out of my head brain.
Thanks again!
Showing 1-5 of 5 comments
< >
The Resonte! Oct 26, 2013 @ 7:34pm 
Can you see any bones? Or the XYZ Arrows?
UniverseBear Oct 26, 2013 @ 9:08pm 
No I can't see bones or XYZ arrows. It's just completely black, like as if I had never loaded a map at all even though it does load.
UniverseBear Oct 26, 2013 @ 9:09pm 
This is what my console says when I load a map:

Team Fortress
Map: cp_well
Players: 1 (0 bots) / 24 humans
Build: 5373
Server Number: 1

Attempted to precache unknown particle system "blood_impact_green_01"!
Attempted to precache unknown particle system "blood_impact_green_01"!
Attempted to precache unknown particle system "blood_impact_yellow_01"!
Attempted to precache unknown particle system "blood_impact_yellow_01"!
No pure server whitelist. sv_pure = 0
Forced rebuild of game cache sound 'sound/misc\your_team_lost.mp3'
Forced rebuild of game cache sound 'sound/misc\your_team_won.mp3'
Forced rebuild of game cache sound 'sound/misc\your_team_suddendeath.mp3'
Forced rebuild of game cache sound 'sound/misc\your_team_stalemate.mp3'
Forced rebuild of game cache sound 'sound/ui\tv_tune.mp3'
Forced rebuild of game cache sound 'sound/ui\tv_tune2.mp3'
Forced rebuild of game cache sound 'sound/ui\tv_tune3.mp3'
Couldn't find customization file 'materials/vgui/logos/spray_bullseye.vtf'.
Compressing fragments for UniverseBear(127.0.0.1:27005) (5921 -> 4953 bytes)
Error reading weapon data file for: tf_weapon_lunchbox
CGameEventManager::AddListener: event 'player_damaged' unknown.
CGameEventManager::AddListener: event 'player_damaged' unknown.
CGameEventManager::AddListener: event 'localplayer_winddown' unknown.
Script not found (scripts/vscripts/mapspawn.nut)
Sending full update to Client UniverseBear (UniverseBear can't find frame from tick -1)
Compressing fragments for UniverseBear(127.0.0.1:27005) (7687 -> 6069 bytes)
CBaseEntity::TakeDamage: with inputInfo.GetDamageForce() == vec3_origin
CBaseEntity::TakeDamage: with inputInfo.GetDamageForce() == vec3_origin
CBaseEntity::TakeDamage: with inputInfo.GetDamageForce() == vec3_origin
UniverseBear connected
Receiving uncompressed update from server
Set Gravity 800.0 (0.250 tolerance)
ModelLoad: preloading session .mdls
ModelLoad took 0.002 msecs
material "vgui/../" not found.
--- Missing Vgui material vgui/..\
Redownloading all lightmaps
R_RedownloadAllLightmaps took 264.098 msec!
Achievements disabled: cheats turned on in this app session.
Server cvar 'mp_respawnwavetime' changed to 9999999
Server cvar 'mp_respawnwavetime' changed to 9999999
Server cvar 'mp_disable_respawn_times' changed to 1
Server cvar 'mp_disable_respawn_times' changed to 1
Server cvar 'mp_teams_unbalance_limit' changed to 30
Server cvar 'mp_teams_unbalance_limit' changed to 30
Server cvar 'sv_tags' changed to norespawntime,r
Server cvar 'sv_tags' changed to norespawntime,r
Unknown command: heartbeat
raptornx01 (banned) Oct 27, 2013 @ 6:04am 
you are probably outside the map somewhere. remember you have to left click the viewport before it will look around.

also it may help to disable lighting. right click the viewport and select disable lighting.
Pte Jack Oct 27, 2013 @ 8:16am 
hahahahaha, I was confused when I opened MTT_Heavy up too. My screen was black the entire time I played the movie. But, here's the fix. Meet the Heavy opens with focus on the work camera, which is located in the dark basement. Switch your camera to the scene camera to view the movie and work with the animations.

As for the map loading problem, as Raptorn says, you are probably off the map. Follow his instruction to find out.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Oct 26, 2013 @ 6:59pm
Posts: 5