Source Filmmaker > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Heinrick 17 Οκτ, 2013 @ 5:27μμ
Problem
Whenever I record in-game in SFM, whenever I fire, the model does no animation, Also, models are dark and flash betwee light and dark. Any way to fix this? Only started recently
Εμφάνιση 1-15 από 15 σχόλια
< >
Sarsour 19 Οκτ, 2013 @ 4:05πμ 
All I can suggest with given info is, try validating your cache files. (right click source filmmaker in steam library, click properties , local files tab, then verify integrity)
Heinrick 19 Οκτ, 2013 @ 11:03πμ 
Nope, that didn't work. Weapons still flash, and when I fire a weapon, the world model just sits there...like it's just idle.
R234 19 Οκτ, 2013 @ 3:01μμ 
It's normal, TF2 does that too in third person. Somehow the character you're playing as will not play the fire sequence. Just import it manually over the character's animation, it's a layer sequence so it'll blend seamlessly with any movement he might be engaged in.

The dark flickering models you speak of, I assume you mean the weapons? That's also "normal", SFM always does that. You'd best delete the weapon model and import and bonemerge a new one to the character.
Heinrick 19 Οκτ, 2013 @ 3:30μμ 
Ahhh, thank you. I didn't think importing a sequence to the arms. And about the weapon, exactly how do you bonemerge? I've tried for a long time..
Τελευταία επεξεργασία από Heinrick; 19 Οκτ, 2013 @ 3:31μμ
R234 19 Οκτ, 2013 @ 5:10μμ 
Well, the simple way is to drag the character's animation set onto the weapon's animation set, and then apply the zero preset to the weapon's animation set. Sometimes though that doesn't work right. In such a case, you'll have to manually lock the weapon's bones to those of the same name on the character.
Sarsour 20 Οκτ, 2013 @ 6:10πμ 
nice!
Heinrick 20 Οκτ, 2013 @ 9:10πμ 
Whenever I do that, the weapon moves around, but won't follow the player(?)
Τελευταία επεξεργασία από Heinrick; 20 Οκτ, 2013 @ 11:48πμ
R234 20 Οκτ, 2013 @ 11:42πμ 
You must've forgotten to apply the zero preset?
Heinrick 20 Οκτ, 2013 @ 11:49πμ 
How do you do that, exactly?
R234 20 Οκτ, 2013 @ 11:49πμ 
Select the hat, slide the zero slider all the way to the right.
Heinrick 20 Οκτ, 2013 @ 11:50πμ 
Ahhh, thank you. Oh, and sorry about the error, I was talking about a gun.
Τελευταία επεξεργασία από Heinrick; 20 Οκτ, 2013 @ 11:50πμ
R234 20 Οκτ, 2013 @ 11:52πμ 
Hats and weapons work the same anyhow ;)
Heinrick 20 Οκτ, 2013 @ 11:52πμ 
Yeah, and thanks again for your help.
Braxton Gaming 20 Οκτ, 2013 @ 12:20μμ 
Hey, could you help with the zero thing? like give specific instructions, please. I did that, and my hat went all the way across the map and didn't even do anything.
raptornx01 20 Οκτ, 2013 @ 12:29μμ 
you have to lock it to something first. drag the weapon bone, hand, head, whatever you plan to lock it to. THEN slide the slider.

note: sometimes you can even drag the entire model to the hat/weapon/whatever model and that'll work too.
Εμφάνιση 1-15 από 15 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 17 Οκτ, 2013 @ 5:27μμ
Αναρτήσεις: 15