Source Filmmaker

Source Filmmaker

frankenhomie Oct 13, 2013 @ 12:08pm
byte'd beak?
Hey:)
I have encountered a problem with the eyes on the robo_medic_blighted_beak.
They only stay white even when being painted.
I havent used SFM in a while and I would've though that this would have been fixed
Thanks,
cyber-
< >
Showing 1-9 of 9 comments
R234 Oct 13, 2013 @ 2:01pm 
That's the same problem I run into in the past with the Doublecross-Comm. You can't count on anybody but yourself to fix it on your end, so here's how.

Go to Steam/SteamApps/common/SourceFilmmaker/game/tf/materials/models/workshop/player/items/medic/robo_medic)blighted_beak/. Open robo_medic_blighted_beak.vmt and robo_medic_blighted_beak_blue.vmt in notepad. Replace their contents with these:

robo_medic_blighted_beak.vmt
"UnLitGeneric" { "$basetexture" "models/workshop/player/items/medic/robo_medic_blighted_beak/robo_medic_blighted_beak_color" "$lightwarptexture" "models/lightwarps/robot_lightwarp" "$phong" "1" "$phongexponent" "10.000000" "$phongboost" "3.000000" "$phongfresnelranges" "[.25 .5 1]" "$rimlight" "1" "$rimlightexponent" "3.000000" "$rimlightboost" "2.000000" "$blendtintbybasealpha" "0" "$blendtintcoloroverbase" "0" "$colortint_base" "{ 249 31 40 }" "$color2" "{ 249 31 40 }" "$colortint_tmp" "[0 0 0]" "$bumpmapalphaphongmask" "1" "$cloakPassEnabled" "1" // "$detail" "effects/tiledfire/fireLayeredSlowTiled512" // "$detailscale" "5" // "$detailblendfactor" "0" // "$detailblendmode" "6" // "$yellow" "0" // ">=DX90" // { // "$selfillum" "1" // } // "$selfillumtint" "[1 1 1]" "proxies" { "weapon_invis" { } "AnimatedTexture" { "animatedtexturevar" "$detail" "animatedtextureframenumvar" "$detailframe" "animatedtextureframerate" "30" } "BurnLevel" { "resultVar" "$detailblendfactor" } "YellowLevel" { "resultVar" "$yellow" } "Equals" { "srcVar1" "$yellow" "resultVar" "$color2" } "ItemTintColor" { "resultVar" "$colortint_tmp" } "SelectFirstIfNonZero" { "srcVar1" "$colortint_tmp" "srcVar2" "$colortint_base" "resultVar" "$color2" } } }
robo_medic_blighted_beak_blue.vmt
"UnLitGeneric" { "$basetexture" "models/workshop/player/items/medic/robo_medic_blighted_beak/robo_medic_blighted_beak_blue_color" "$lightwarptexture" "models/lightwarps/robot_lightwarp" "$phong" "1" "$phongexponent" "10.000000" "$phongboost" "3.000000" "$phongfresnelranges" "[.25 .5 1]" "$rimlight" "1" "$rimlightexponent" "3.000000" "$rimlightboost" "2.000000" "$blendtintbybasealpha" "0" "$blendtintcoloroverbase" "0.000000" "$colortint_base" "{ 31 214 249 }" "$color2" "{ 31 214 249 }" "$colortint_tmp" "[0 0 0]" "$bumpmapalphaphongmask" "1" "$cloakPassEnabled" "1" // "$detail" "effects/tiledfire/fireLayeredSlowTiled512" // "$detailscale" "5" // "$detailblendfactor" "0" // "$detailblendmode" "6" // "$yellow" "0" // ">=DX90" // { // "$selfillum" "1" // } // "$selfillumtint" "[1 1 1]" "proxies" { "weapon_invis" { } "AnimatedTexture" { "animatedtexturevar" "$detail" "animatedtextureframenumvar" "$detailframe" "animatedtextureframerate" "30" } "BurnLevel" { "resultVar" "$detailblendfactor" } "YellowLevel" { "resultVar" "$yellow" } "Equals" { "srcVar1" "$yellow" "resultVar" "$color2" } "ItemTintColor" { "resultVar" "$colortint_tmp" } "SelectFirstIfNonZero" { "srcVar1" "$colortint_tmp" "srcVar2" "$colortint_base" "resultVar" "$color2" } } }
The lenses should then be red/blue as they should, and you can paint them by manipulating the $colortint_tmp attribute.
frankenhomie Oct 13, 2013 @ 2:21pm 
Cheers man you're awesome.
Also I thought it was a SFM problem, not a material problem :)
Thanks again:>
R234 Oct 13, 2013 @ 2:26pm 
Originally posted by •иєвυℓα. cyber-:
Cheers man you're awesome.
Also I thought it was a SFM problem, not a material problem :)
Thanks again:>
Well, it's kinda a SFM problem, in the sense that SFM runs on an older version of the Source Engine than TF2 does, so some TF2 effects aren't supported properly. Lest they either re-build SFM from the ground up, or look over every single TF2 item one by one to make sure everything complies to SFM, both of which I don't expect them to do any time soon (rightly so), it's up to us to fix the litlle problems we run into from time to time. No big deal ;)
Cap'n Potato Sep 23, 2015 @ 12:24pm 
Thanks man! But when i paint the eyes the way you suggest, the eyes glow. When i use a paint script, it works though. Thanks!
Casylum Dec 20, 2015 @ 9:38am 
Thank you!!
Void Egg Jul 10 @ 11:14pm 
Sorry to raise this thread from the grave, but I'm having trouble with the Byte'd beak model as well, and, after trying everything in this thread (and other things as well) I'm still stuck with a Byte'd beak model that has unchangeable, unpaintable white eyes. Is there something I'm missing here or is there no fix for this?
R234 Jul 10 @ 11:57pm 
Originally posted by Void Egg:
Sorry to raise this thread from the grave, but I'm having trouble with the Byte'd beak model as well, and, after trying everything in this thread (and other things as well) I'm still stuck with a Byte'd beak model that has unchangeable, unpaintable white eyes. Is there something I'm missing here or is there no fix for this?
If editing the material files in the TF mod does not work, you probably have duplicate files in a higher priority mod. A lot of people make that mistake when manually updating the TF2 contents in SFM (even worse when they do so in usermod). Make sure that's not the case for you.
Void Egg Jul 11 @ 12:10am 
Originally posted by R234:
Originally posted by Void Egg:
Sorry to raise this thread from the grave, but I'm having trouble with the Byte'd beak model as well, and, after trying everything in this thread (and other things as well) I'm still stuck with a Byte'd beak model that has unchangeable, unpaintable white eyes. Is there something I'm missing here or is there no fix for this?
If editing the material files in the TF mod does not work, you probably have duplicate files in a higher priority mod. A lot of people make that mistake when manually updating the TF2 contents in SFM (even worse when they do so in usermod). Make sure that's not the case for you.
Oh geez, yep. That was the problem. Thank you so much!
Void Egg Jul 11 @ 12:55am 
One last question, I'm having a similar problem with the Phobos filter for pyro(white eyes), will the same fix here work with that one?
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Oct 13, 2013 @ 12:08pm
Posts: 9