Source Filmmaker > 综合讨论 > 主题详情
Ferhod 2013年10月30日上午9:33
Models disappearing from certain angles
Models imported from Gmod, completely vanishes when I look at them from certain angles. I found out that it happens if I look far away from the origin (not the root). Therefore, it seems like this is because the engine thinks the object is not within the camera view.

The objects still have their shadows when the they disappear.
I have already tried moving the root within the view - No success.


Any help is highly appreciated.

If you're interested in checking out the models yourself here are the links:
Gmod MBilliards mod: http://facepunch.com/showthread.php?t=1054212
File download source: http://mbilliards.googlecode.com/svn/trunk/
Tiny program used for downloading the files: http://downloadsvn.codeplex.com/
正在显示第 1 - 8 条,共 8 条留言
< >
raptornx01 2013年10月30日上午10:13 
I think this is a known glitch with some models. I recently came across a model of a wall that i think is in sfm by default that disappears when you get close to it. I'm not sure waht causes this or how to fix it without decompiling the model (if it can be fixed that way)
Ferhod 2013年10月30日上午11:42 
Huh, ok. There has to be a solution.
R234 2013年10月30日下午2:25 
Yeah, it's due to a process called frustum culling, which makes it so that when a model is off-screen, it isn't rendered to save on GPU power. Very useful in video games, not so much in a CG movie program, especially when it's buggy, which it often is with Gmod models in SFM.

From what I can gather, commenting out "$hboxset" in the model's QC file is the only way to fix that. So yes, it needs to be decompiled.
Ferhod 2013年10月30日下午2:44 
Ah, ok. I will give that a try. Thanks a lot!
Ferhod 2013年10月31日下午3:29 
Yup, it works!
R234 2013年10月31日下午4:22 
Awesome, another confirmation :)
NieOrginalny™ 2013年12月27日上午7:01 
Sorry for necro, but can someone explain how to do that?
EpicLPer 9月28日上午6:51 
"From what I can gather, commenting out "$hboxset" in the model's QC file is the only way to fix that. So yes, it needs to be decompiled."


Thanks for this tip, I tried to do that on the "Chromapanels" too but there is no $hboxset in the decompiled model QC. I used Crowbar to decompile.
Any other solutions for this already?
正在显示第 1 - 8 条,共 8 条留言
< >
每页显示数: 15 30 50