Australium HALP! D:
Trying to get back into SFM poster making and was making sure I was up to date with the newest content. Unfortunately, the Scattergun seems to be having issues with its Australium skin. I imported the Force-A-Nature model and switched it to Australium with no problem. Just had to change the skin. However, the scattergun won't cooperate :(
http://i.imgur.com/NMRKgJt.png
Any ideas?

So far, the scattergun seems to be the only one having this issue.
Last edited by ⁻ᴰᴳᴺ⁻ Cmp™ - UNAVAILABLE!; Jan 20 @ 5:48pm
Showing 1-14 of 14 comments
< >
R234 Jan 20 @ 6:17pm 
Oh, you're right. Somehow the Scattergun uses the wrong envmap texture.

Go to C:\Program Files (x86)\Steam\SteamApps\common\SourceFilmmaker\game\tf\materials\models\weapons\w_scattergun\, and open w_scattergun_gold.vmt in a text editor. Look for the line that says "$envmap" just above "$envmaptint" "[2.5 2.5 1.15]". Change it to: "$envmap" "cubemaps/cubemap_gold001"

Oh, while you're at it, set "$detailblendfactor" to "0" instead of ".01", that'll remove the fire overlay that's slightly visible on the grip.
Awesome! That worked! Thanks, R234! =D
Hayden the PotatOS May 25 @ 6:45am 
Quite annoying that we have to fix this manually. I know SFM is still in beta, but COME ON, VALVE!
R234 May 25 @ 9:47am 
Eh, I can't complain. It forces us to go digging and learn stuff, which prepares us for making our own assets :D
★TS★TechSandvich☁♪☊ Jun 29 @ 10:21am 
Thanks , It's Working :)
Last edited by ★TS★TechSandvich☁♪☊; Jul 15 @ 8:18am
Levogevo Jul 16 @ 9:58am 
https://i.imgur.com/hmKVPpv.png comparison if anyone doesnt know or wants to know. :P
It did work R234 thanks!
Jeffro_ Jul 30 @ 12:40pm 
for some reason in actual tf2 i have the same problem with the fiery handle. is there a way to fix that to that you know of? and thanks for the sfm fix!
Originally posted by R234:
Oh, you're right. Somehow the Scattergun uses the wrong envmap texture.

Go to C:\Program Files (x86)\Steam\SteamApps\common\SourceFilmmaker\game\tf\materials\models\weapons\w_scattergun\, and open w_scattergun_gold.vmt in a text editor. Look for the line that says "$envmap" just above "$envmaptint" "[2.5 2.5 1.15]". Change it to: "$envmap" "cubemaps/cubemap_gold001"

Oh, while you're at it, set "$detailblendfactor" to "0" instead of ".01", that'll remove the fire overlay that's slightly visible on the grip.
Chakra - I Do SFMs Aug 17 @ 5:16am 
Hi. I have tried to open this file in Word, Notepad and Notepad ++. I can't find the line anywhere. Any suggestions?
R234 Aug 17 @ 8:29am 
Originally posted by Chakra - I Do SFMs:
Hi. I have tried to open this file in Word, Notepad and Notepad ++. I can't find the line anywhere. Any suggestions?
Are you sure you opened the right file?
Sir Emerald LXIV Sep 21 @ 9:43am 
Hello.
I've tried all that you said, R234, but it still doesn't work for me.


I've tried putting "materials/" before "cubemaps/cubemap_gold001" to see if SFM was just having problems locating the file...

I've tried removing all my downloaded workshop items...

I've tried turning off "mat_specular", which seems to always turn on after starting up SFM...

I've tried looking back on what you said and instead opened the "Valve Material File" in "Notepad++" but still didn't help...

Also, the flames on the Australium Scattergun are still there even after setting "$detailblendfactor" to "0".


If you have the time to reply and help me out, that would be great.
R234 Sep 21 @ 1:43pm 
Did you type mat_reloadallmaterials in the console (or restart SFM) after applying the changes? If so, you most likely either edited the wrong file, forgot to save the changes, or have an overriding material of the same name in a higher priority mod.
Sir Emerald LXIV Sep 21 @ 3:16pm 
I tried what you said, and it still didn't work...

But...

When I made a new session and put the same Australium Scattergun I put in a previous session, it worked.
Apparently, SFM doesn't change the properties of a model that's been saved on session with different model properties.

But it isn't too much of a bother to fix now, I just have to create a new Scattergun model.

Thanks for the help, R234.
Bubble Nov 23 @ 5:59am 
Hey I still have a problem :(
This just fixes the problem for the world model, so w_scattergun
but not for the v_scattergun (firstperson)
and Ideas how to fix the v_scattergun? because in its textfile it already has the cubemaps/cubemap_gold001 thing and everything is fine, still it looks wrong ...
Help
R234 Dec 5 @ 1:47pm 
Originally posted by GreenShot:
Hey I still have a problem :(
This just fixes the problem for the world model, so w_scattergun
but not for the v_scattergun (firstperson)
and Ideas how to fix the v_scattergun? because in its textfile it already has the cubemaps/cubemap_gold001 thing and everything is fine, still it looks wrong ...
Help
Hey, sorry it took so long to come back to you. I kept looking at my Steam messages at work where I don't have access to SFM and meant to look into this later, but just plain forgot.

The problem with the viewmodel is a different one. You have to comment out "$detailblendmode" 6.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50