Source Filmmaker > Discussioni generali > Dettagli della discussione
Lilyn Sen 14 gen, ore 6:11
Dota 2 sequence import issue
Hello everyone. I'm a complete newbie at SFM so I apologize if it's just a case of me missing something really obvious, or if it's already been posted somewhere else. I couldn't find an answer anywhere.

I've followed the most popoular guides and I could successfuly import Dota 2 static models and their respective parts, but I can't seem to get their sequences to work at all.

As you can see here http://it.tinypic.com/view.php?pic=21c8sip&s=5#.UtVEXPTuLCs (Hoping external links are allowed and that I didn't goof miserably) the model looks fine but while I get the correct list of animations, I can't see the preview, and even if I try to import it regardless, it has no visual effect.

I suspect the same problem is causing this odd, but otherwise harmless transparency when selecting a model: http://it.tinypic.com/view.php?pic=2m3gpk9&s=5#.UtVE4PTuLCs.

My first assumption was that I made a mistake with the whole extraction process, but I've since re-done the whole thing three times, even reinstalled SFM from scratch, and the issue persists.

Thanks in advance!


Visualizzazione di 1-14 commenti su 14
< >
R234 14 gen, ore 10:40 
You did no mistake, that's normal. If I had those models handy I could look into potentially fixing those menus without altering the actual model's quality, but it's very unlikely.

Hm... perhaps a temporary version of the texture would be a viable workaround though, now that I think about it....... Let's see...

EDIT:

Oh, I know, you could try this: Find the material file (.vmt) the model uses, and make sure SFM cannot find it, either by renaming it or moving it. If I'm right, the model should become pink and black checkered, but it should also be visible in the preview windows. If that works, we can look into a more elegant workaround if you want.
Ultima modifica da R234; 14 gen, ore 10:58
Lilyn Sen 14 gen, ore 11:31 
Thanks for the great tip :) I will give it a go right now. I thought there was something wrong on my end because the guides I've followed seem to have completely functional preview windows.

My biggest concern though was that animations weren't playing at all in the main scene even if I selected a sequence, the model kept standing still, but now they're working. I have no idea what was wrong. So at least that's sorted out!
Ultima modifica da Lilyn Sen; 14 gen, ore 11:32
Pte Jack 14 gen, ore 11:43 
Yeah, it is a pain. The DOTA2 shader in the vmt (first line) is called CustomHero and should changed to vertexlitgeneric, even after doing that, the models remain invisible or slightly visible in the model browser.
R234 14 gen, ore 11:45 
Could one of you post the whole contents of one of the problematic models' .vmt in here, so I can have a look?
Pte Jack 14 gen, ore 12:47 
@R234, I don't have problems with my install of Dota2, we'll have to wait for something from Lilyn Sen. Now that the DX80 and SW.vtx files are no longer required by SFM, a lot of the people that follow the Cyborg Matt tut are experiencing problems after running the .bat to create the missing files. This step isn't required anymore, but the rename of the CustomHero shader in the vmts to VertexLitGeneric still is.
Lilyn Sen 14 gen, ore 14:07 
Ok here I am! Sorry, I had no idea someone was waiting for a report.

So, the workaround definitely does what it should: http://it.tinypic.com/view.php?pic=11m3uit&s=5#.UtWtJfTuLCs, even if it's not the most convenient procedure, it's better than nothing.

With a bit of trial and error I've found that in this particular case (Vengeful Spirit model), the .vmt that gives it transparency is likely to be vengeful2_body_color.vmt: http://it.tinypic.com/view.php?pic=2w4iozk&s=5#.UtW0YvTuLCs.

With all the other files present and just by removing that one it reverts to the solid pink/black square look. This is the contents:

"VertexLitGeneric"
{
"$baseTexture" "models/heroes/vengeful/vengeful2_body_color"
"$normalmap" "models/heroes/vengeful/vengeful2_body_normal"
"$diffusewarp" "models/heroes/sven/sven_diffusewarp"
// $FRESNELWARP "models/heroes/dragon_knight/dragon_knight_fresnelranges"
"$maskmap1" "models/heroes/vengeful/vengeful2_body_mask1"
"$maskmap2" "models/heroes/vengeful/vengeful2_body_mask2"
"$detail1" "models/heroes/vengeful/vengeful_glow"

$SPECULAR_BLOOM_SCALE 1
$SPECULAREXPONENT 13
$SPECULARSCALE 60
$SPECULARCOLOR "[0.7 0.9 1]"
$RIMLIGHTCOLOR "[0.5 0.8 0.9]"
//$SPECULARBLENDTOFULL 1
$alphatest 1

$RIMLIGHTSCALE 10

$DETAIL1BLENDMODE 3
$DETAIL1SCALE 1
$DETAIL1BLENDFACTOR 2
// $DETAIL1BLENDTOFULL 0




"$cloakPassEnabled" "1"
"Proxies"
{
"TextureScroll"
{
"texturescrollvar" "$detail1texturetransform"
"texturescrollrate" "0.1"
"texturescrollangle" "90"
}
"invis_proxy"
{
}
"status_proxy"
{
}
"hero_proxy"
{
}
}

}
Ultima modifica da Lilyn Sen; 14 gen, ore 14:07
R234 14 gen, ore 14:40 
Pretty sure $alphatest 1 is the cause of this. I bet commenting that line out would also fix the previews, though it might have a bit of an adverse effect on the model's appearance. Just not nearly as much as removing the whole material ;)
Lilyn Sen 14 gen, ore 14:51 
That definitely works, and I see no obvious differences in the actual model :)

Thanks a lot! It's definitely one of these moments when I wish I knew my way around these things better ^^
Pte Jack 14 gen, ore 18:21 
We've all been there and using the tool is a daily lesson. R234 is probably one of the best authorities out there for this type of problem. Always a learning experience reading his posts.
Heisenberg 14 gen, ore 19:46 
Messaggio originale di Lilyn Sen:
That definitely works, and I see no obvious differences in the actual model :)

Thanks a lot! It's definitely one of these moments when I wish I knew my way around these things better ^^

Hi Lylyn Sen,

It seems your problem has been resolved? I have exactly the same problem with you. I would appreciate if you could explain more clearly how did you fix these issues.
PalmliX 15 gen, ore 7:22 
A very talented SFM user called BlueFlyTrap has been painstakingly updating all the DOTA heros for use in SFM, including higher res textures, I don't know if it would fix the transparent model viewer issue but the textures are far superior to what you get straight from the game: http://facepunch.com/showthread.php?t=1300754
Ultima modifica da PalmliX; 15 gen, ore 7:22
Lilyn Sen 15 gen, ore 10:16 
Messaggio originale di Heisenberg:
Messaggio originale di Lilyn Sen:
That definitely works, and I see no obvious differences in the actual model :)

Thanks a lot! It's definitely one of these moments when I wish I knew my way around these things better ^^

Hi Lylyn Sen,

It seems your problem has been resolved? I have exactly the same problem with you. I would appreciate if you could explain more clearly how did you fix these issues.

I simply opened the .vmt that caused the transparency with notepad and deleted the $alphatest 1 line. The vmt for heroes and their respective parts should all be in materials/models/heroes.

To find the one particular .vmt causing the problem I had to do a bit of trial and error by adding the suspect ones (example "vengeful skin color" "vengeful body color") and then see which one caused the change. Perhaps there is a more elegant way, but that's all I could do :)

Messaggio originale di PalmliX:
A very talented SFM user called BlueFlyTrap has been painstakingly updating all the DOTA heros for use in SFM, including higher res textures, I don't know if it would fix the transparent model viewer issue but the textures are far superior to what you get straight from the game: http://facepunch.com/showthread.php?t=1300754

I'm really glad someone has been working on high definition models. Sadly I won't be on a proper pc for 1-2 days so it'll take me a while, but I'll try them out! Thanks!
Pte Jack 15 gen, ore 14:19 
Lilyn Sen, There is a search and replace function in Notepad ++ that will allow you to search folders and replace the $alphaTest occurance in all files by extension in 1 foul swoop.
Lilyn Sen 15 gen, ore 14:28 
I've actually already done that, but it doesn't seem to work for all models. : \
Visualizzazione di 1-14 commenti su 14
< >
Per pagina: 15 30 50
Data di pubblicazione: 14 gen, ore 6:11
Messaggi: 14