Source Filmmaker > 一般討論 > 主題細節
森林 2013 年 12 月 30 日 @ 下午 1 時 02 分
I require help with models. [RESOLVED]
So i'm trying to get the "shirtless" models from Rebaccus to work in SFM. I got the Unmasked spy from maxofs2d's downloading page and that works but the rebaccus models don't seem to Work. I put them all in the Game>TF section. Did i place them incorrectly? Please help me out as soon as possible, it's really getting to me and i can't figure it out for my life!
最後修改者:森林; 01 月 1 日 @ 下午 6 時 43 分
顯示 1-15,共 15 則回應
< >
R234 2013 年 12 月 30 日 @ 下午 1 時 05 分 
You should put them in usermod or a custom mod instead of TF, but they should work regardless. What do you mean by "don't seem to work", do they not appear at all in the list, are they invisible, or are they pink and black checkered? If they do show up in the list, what error messages does the console report?
森林 2013 年 12 月 30 日 @ 下午 1 時 09 分 
They don't show up in the list at all, i've been searching constantly, i've tried every keyword and looked through every subfolder in the list. It says nothing about those specific models but it is saying quite often "failed to load models" but that might've been the effect of the shrek model i have, it does that from time to time.
R234 2013 年 12 月 30 日 @ 下午 1 時 19 分 
You probably installed them incorrectly. I see they come in a folder called "TF2 Shirtless Models", which includes "materials", "models" and "settings" folders as well as an info.txt file. You know you have to merge only the materials and models folders in your chosen mod folder (again, I suggest not using TF) instead of copying the whole thing in there, right?
森林 2013 年 12 月 30 日 @ 下午 1 時 24 分 
oh. Well ♥♥♥♥. alright. thanks i'll try it.
森林 2013 年 12 月 30 日 @ 下午 1 時 35 分 
So i retried installing and i put them in usermod and merged the models and materials. Still not working. i think i'll have to do this video with shirts on sadly.
R234 2013 年 12 月 30 日 @ 下午 1 時 38 分 
That really isn't normal. What's the full filepath to your model files, starting from your SourceFilmmaker folder?
森林 2013 年 12 月 30 日 @ 下午 1 時 42 分 
R234 2013 年 12 月 30 日 @ 下午 2 時 22 分 
I mean the models proper, srtls_demo.mdl for instance.
最後修改者:R234; 2013 年 12 月 30 日 @ 下午 2 時 23 分
森林 2013 年 12 月 30 日 @ 下午 3 時 59 分 
I'm sorry i don't follow, like what's the name of my files?
R234 2013 年 12 月 30 日 @ 下午 4 時 58 分 
My point is the actual model files should be in SourceFilmmaker/game/usermod/models/player/, and the material files should be in SourceFilmmaker/game/usermod/materials/models/player/[class]/. If that's the case there's no reason why SFM wouldn't be able to load them.
森林 2013 年 12 月 30 日 @ 下午 5 時 03 分 
Oh yeah, they are. Yeah i don't know why it's not loading them. Sorry for the misunderstanding but yeah they are in the correct filepaths. It's got to be something with my SFM then?
R234 2013 年 12 月 30 日 @ 下午 5 時 07 分 
Hm, well, sometimes there might be a space in the model import dialog's search field, or maybe the wrong mod is selected in the drop-down at the top. If you haven't restarted SFM since adding them you'd have to hit rescan, too. That's really all I can think of though :/
森林 2013 年 12 月 30 日 @ 下午 5 時 08 分 
Alright. I'll just stick to my original video idea then! thanks anyways dude.
Pte Jack 2013 年 12 月 31 日 @ 上午 1 時 18 分 
Link me to the models... I have a sneaking suspicion I know what's wrong.
森林 01 月 1 日 @ 下午 6 時 43 分 
I would like to point out that on new years i have resolved this. it is no longer a problem, they fixed themseleves after i restarted steam. everything works perfectly now, thanks!
顯示 1-15,共 15 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 12 月 30 日 @ 下午 1 時 02 分
回覆: 15