Source Filmmaker > 一般討論 > 主題細節
SamSpielberg 2013 年 12 月 10 日 @ 下午 6 時 16 分
Spy Gloves Help [FIXED]
So, my spies have a weird glove glitch. On the back side of the hand there's a black part that goes across the knuckles of the fingers. The rest of the hand is a red or blu glove. They look really ugly. Any fix?
最後修改者:SamSpielberg; 2013 年 12 月 12 日 @ 下午 6 時 09 分
顯示 1-15,共 15 則回應
< >
SamSpielberg 2013 年 12 月 10 日 @ 下午 8 時 10 分 
Bump
R234 2013 年 12 月 10 日 @ 下午 9 時 48 分 
Is that the basic TF2 Spy models? You didn't import anything into SFM? Got a screenshot of that?
SamSpielberg 2013 年 12 月 11 日 @ 上午 9 時 09 分 
Yes. No, Nothing that should affect the basic spy model, and I'll see if I can get one.
SamSpielberg 2013 年 12 月 11 日 @ 上午 9 時 24 分 
http://steamcommunity.com/sharedfiles/filedetails/?id=202974604

http://steamcommunity.com/sharedfiles/filedetails/?id=202974434
The same thing happens with the red spy, but he has a skin with black gloves. However, I need the blu spy for this project and his ugly gloves are in the way.
R234 2013 年 12 月 11 日 @ 下午 6 時 05 分 
You sure you didn't install any custom models or materials that could affect the Spy? There's pretty much nothing else that could've caused the UV map to screw up like that...
SamSpielberg 2013 年 12 月 11 日 @ 下午 6 時 15 分 
Well, not that I'm aware of, but I do have a lot of stuff in SFM.
SamSpielberg 2013 年 12 月 11 日 @ 下午 6 時 23 分 
In GCFScape I found something called 'spy_hands_normal.vtf' in the tf2 textures dir, along with spy_hands_blu/spy_hands_red.vtf that are not in SFM. Slapped 'em in and trying now.
最後修改者:SamSpielberg; 2013 年 12 月 11 日 @ 下午 6 時 24 分
SamSpielberg 2013 年 12 月 11 日 @ 下午 6 時 40 分 
Non-HWM spies are fine.....
SamSpielberg 2013 年 12 月 11 日 @ 下午 6 時 43 分 
Where would I look in my computer? Is this a texture bug or a model bug or something else?
R234 2013 年 12 月 11 日 @ 下午 6 時 44 分 
Be with you in a minute, I'm checking on something else.
SamSpielberg 2013 年 12 月 11 日 @ 下午 6 時 45 分 
No Prob. Take your time.
R234 2013 年 12 月 11 日 @ 下午 6 時 57 分 
So it's just the HWM Spy's gloves. Les'see...

EDIT:

Ah, I think I got it. This is the Spy texture that's in the "tf" mod folder:
http://i.imgur.com/mK441Kj.jpg

And that's the Spy's texture in "tf_movies":
http://i.imgur.com/wxFM9cg.jpg

Normally, tf_movies takes precedence over tf, and apparently they used that grey square replacing the mask portion of the texture to map the HWM model's gloves. Somehow though in your case the regular texture is displayed instead, and that's why the the mask appears "painted" on the hands.

I can see three ways that could have happened; either you swapped tf and tf_movies' priority around in gameinfo.txt, you imported the TF2 textures in tf_movies, or you imported the TF2 textures in another mod folder that takes priority over tf_movies, like usermod.

In the first two cases, validating your cache files should fix it. If it's the latter though, you might have to navigate your mod folders that have priority over tf_movies, and delete any textures that can conflict with the TF2 characters.
最後修改者:R234; 2013 年 12 月 11 日 @ 下午 7 時 17 分
SamSpielberg 2013 年 12 月 11 日 @ 下午 7 時 23 分 
Cool, that makes sense. Thank you, sir, I'll try that out ASAP.
SamSpielberg 2013 年 12 月 12 日 @ 下午 6 時 07 分 
So, I haven't done this yet, but what would happen if I deleted the entire usermod folder?
SamSpielberg 2013 年 12 月 12 日 @ 下午 6 時 09 分 
NVM, just fixed. Found an extra spy texture folder in usermod and deleted the whole thing. Totally fixed it. Thank you so much for your time, I owe you one!
最後修改者:SamSpielberg; 2013 年 12 月 12 日 @ 下午 6 時 13 分
顯示 1-15,共 15 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 12 月 10 日 @ 下午 6 時 16 分
回覆: 15