Source Filmmaker

Source Filmmaker

sonosublime May 17, 2014 @ 9:39pm
Graph editor mayhem
Hi all,

I am trying to do some manual lip-sync using the graph editor. The thing is, I am trying to add some lip-sync in between two portions of a shot that already have lip-sync going on (as well as facial manipulation - i.e. a smile at the end).

As you can see from the below pictures, when I add a bookmark in between, it screws around with the lines. How exactly can I stop this from happening?

Picture 1 (before):

Picture 2 (after adding bookmark):

As you can see, when I add a bookmark in between, it screws around with the lines. How exactly can I stop this from happening?

I think the main problem is that (viewing Picture 1) in between the two lip-sync portions, the graph editor automatically adds those curved lines, even though I have not edited the model in any way there.

Thanks in advance.
< >
Showing 1-6 of 6 comments
ClinterinoM0 | C: May 17, 2014 @ 9:47pm 
You shouldn't be bookmarking the whole body in the first place except for the first frame. Use overlapping action to create more realistic animation.
sonosublime May 17, 2014 @ 10:53pm 
Well, I didn't bookmark the whole body. I only select the 'middle face', 'lower face' and 'tongue' subsections of the 'face' portion of the model when I do manual lip-sync.

And I'm not really concerned about more realistic animation right now, just how I can add a bookmark where I need it without messing everything else up.
Last edited by sonosublime; May 17, 2014 @ 10:54pm
ClinterinoM0 | C: May 17, 2014 @ 11:13pm 
Auto Lip-sync does not add bookmarks. The best solutions are to blade the clips if that's possible for your situation or add many keys manually to ensure the lip-sync still works.
raptornx01 May 18, 2014 @ 7:02am 
try toggling On offset mode.
sonosublime May 18, 2014 @ 8:32am 
Thanks guys,I managed to get it working.

What exactly is the difference between Offset, Auto Frame Curves and Normalize Curve Display of the Graph Editor?
psi onix May 20, 2014 @ 4:52pm 
i don't know the exact technical differences but raptor's suggestion should have worked because the offset mode thing stops the keys' curves from affecting one another as a whole and operate on thier own curve (or something). Is toggling that on what stopped your problem?

Another thing you can try when animating in general is setting in additional placement bookmarks, for example, before that second set of your lipsync there. A new placement bookmark tells the animation that it's starting point is from there... that way it's not trying to curve everything all the back from the first set of lipsync animation.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Date Posted: May 17, 2014 @ 9:39pm
Posts: 6