QuortaZ Apr 23 @ 3:57am
SFM CTDs when opening model into map
Hi
So I recently downloaded a model of Thane from ME2 via garrysmod.org (http://www.garrysmod.org/downloads/?a=view&id=111475) to use in SFM. I copied the "models" and "materials" folders into the "usermod" folder, as many times before, started up SFM, loaded a session and map.
Then I did the usual "create animation set for new model" found the model, selected it, and hit "open".

Now there are two diffrent models in the file, one with a mask/helmet on his head and one without.
The one with the mask/helmet opens into the map with no problems at all. But naturally the one I need, the one with no mask/helmet, causes SFM to CTD when i press "open".
It somehow still showed up in the preview window to the right of the list and looked just fine, I could even pan around it with no problems.

So then I copied the "models" and "materials" folders into Garry's Mod to see if they worked there, and they did. Both models I was able to spawn into the map just fine with no problems what so ever.

Then I launched the Source SDK (from the same launcher as SFM), opend up the model viewer tool and browsed for the models. Both the models worked even there with no problems at all.

So right now I can't for the love of god figure out what the issue is and need help.
If anyone would be so kind as to help me I would be forever grateful.
Thanks in advance.
Showing 1-4 of 4 comments
< >
R234 Apr 23 @ 4:46pm 
That means the model is incompatible with SFM. You'll need to recompile it.
QuortaZ Apr 24 @ 12:34am 
Fisrt off, thank you for helping me. But I'm afarid recompliling the model did not work.

Here's what I did:

I downloaded the Crowbar Decompliler/Compiler and ran the .mdl file through the decompliler. Now I don't know if i should tick any of the settings under "Create from Decomplile", I just left it as default.

Then I configured Crowbars Compliler to SFM by setting the correct gameinfo.txt and studiomdl.exe.
Then found the folder with the decompiled .qc file and all the other files from the decompile.
I selected the decompiled .qc file and started the compile. There was some errors that caused it to stop the compile, but I removed the faulted lines from the .qc file and the compiler where able to compile it without errors.

The model is still viewable in the modelviewer and it still shows up in the preview window inside SFM, but as soon as i hit open, just like before, SFM freezes for a second and then crashes to desktop.

Now it is highly possible that I did something wrong in the decompiling/compiling process, but I'm definetly not an expert in this are and have no idea of what I might have done wrong.
So now I'm just back at square one again, help still needed.
R234 Apr 24 @ 2:03pm 
There are othe models that do that as well, I was trying to get a few Claire Redfield models to work in SFM but they did the exact same as yours, previewed fine but crashed SFM on import. I looked around and they seemed fairly positive it's something to do with the model, but nobody seems to be able to fix it. I'm afraid it's a pretty complex problem. way above my area of expertise :(
QuortaZ Apr 24 @ 2:30pm 
Oh well, thank you very much for the help anyways, at least now I know it's best to put the project on hold for a while.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Apr 23 @ 3:57am
Posts: 4