Source Filmmaker

Source Filmmaker

KHAAAAAAAAAAAAAN! Apr 7, 2014 @ 11:24pm
Portal 2 maps question: disappearing props
I've just copied and moved a Portal map from the 'portal2' folder in Portal 2 of games and moved it over to SFM. (i moved the WHOLE map folder). I managed to get the core map running, but static props in it do not appear when I am in the normal edit mode, but appear when I run the game/record mode. Does anyone know how to fix this?
< >
Showing 1-5 of 5 comments
6000 ANGRY BEES Apr 7, 2014 @ 11:41pm 
Those would be Dynamic Props, which are handled differently from the rest of the map geometry for various reasons too boring to go into here.

What I do with this is use the right click menu on the viewpoint to Teleport the Player close to where I'm shooting, then click the Record button. In the box that pops up, I untick everything in the first two rows, click "Record", then press ESC as soon as Game Mode kicks in.

Finally, click the "+" in the animation set editor, select Create Animation Set from Existing Elements, and shift-click everything and click OK.

Now all the troublesome Dynamic Props are normal animation sets, automatically grouped away to avoid filling up your animation set column! This means you can animate them, too!
Pte Jack AFK Apr 8, 2014 @ 1:13am 
Well, Son of a B---Gun. I've been wondering how to do this for a while now.

Thanks Boss
raptornx01 Apr 8, 2014 @ 8:48am 
wait, you can animate those? o.O

*gasp* I love you
Last edited by raptornx01; Apr 8, 2014 @ 9:07am
6000 ANGRY BEES Apr 8, 2014 @ 12:25pm 
I should probably make videos of some of these weird tricks I've picked up over the years.
KHAAAAAAAAAAAAAN! Apr 8, 2014 @ 3:18pm 
Oh. My God. Thank you so much. I love you for this ^^
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Apr 7, 2014 @ 11:24pm
Posts: 5