diopaul258 Feb 15 @ 2:50pm
Red X's when i shoot a weapon in Source Filmmaker
Hi, i'm new to SFM. When i go to play mode, i could shoot without the red x's. But after i copied dota 2 hero models over, i get the red x's problem. I tried to verify the files, but it still has the red X's problem. Any help is appreciated.
Showing 1-6 of 6 comments
< >
You've added somenthing to your usermod folder thsat is redirecting SFM from finding the particles required for your scene. I just did a day of reseach on this very problem.

The way I fixed it was to rename the usermod folder to something else and then revalidated the cache. After the download finished I checked the record mode and everything worked.

I renamed the new usersmod to something else and reinstated the old usermod, the problem returned. I changed back to the new usermod and the problem went away again.
Last edited by Pte Jack is away for a MONTH++; Feb 15 @ 4:52pm
raptornx01 Feb 15 @ 4:46pm 
Now you just have to go through the usermod folder files and find the offending item. :3
diopaul258 Feb 15 @ 4:47pm 
OK thanks for the help. The question i have now is if i do that, will my dota 2 files in sfm will get deleted and will i have to transfer them back?
depends on where you put them, if into usermod, then yes, you'll have to move them from the old usermod folder. If you have them in a separate folder under games, you'll have to reedit your new gameinfo.txt and readd the Dota2 folder to the searchpaths.
I will tell you this though, I won't be putting any custom content into my usermod folder. I'll use the build a folder/edit the gameinfo.txt file method from now on. Much easier to debug problems. I've actually created a TeamF2 folder for my extracted TF2 stuff now.
diopaul258 Feb 16 @ 12:41pm 
Thanks for the help. I used the gameinfo.txt method and it work fine. I watched your youtube vids and it helped a lot. Thanks.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Feb 15 @ 2:50pm
Posts: 6