Wondering if anyone has found the fix for SFM not finding the TF2 Particles in GameMode???
Title says it all, but for those that don't understand what I mean...

I'll load SFM and get hit with these type of errors

Attempted to precache unknown particle system "critical_grenade_blue"!
Attempted to precache unknown particle system "critical_grenade_red"!
Attempted to precache unknown particle system "weapon_tracers"!
Attempted to precache unknown particle system "muzzle_syringe"!
Attempted to precache unknown particle system "nailtrails_medic_blue_crit"!
Attempted to precache unknown particle system "nailtrails_medic_blue"!
Attempted to precache unknown particle system "nailtrails_medic_red_crit"!
Attempted to precache unknown particle system "nailtrails_medic_red"!
Attempted to precache unknown particle system "muzzle_sniperrifle"!
Attempted to precache unknown particle system "muzzle_smg"!
Attempted to precache unknown particle system "bullet_pistol_tracer01_red"!
Attempted to precache unknown particle system "bullet_pistol_tracer01_red_crit"!
Attempted to precache unknown particle system "bullet_pistol_tracer01_blue"!
Attempted to precache unknown particle system "bullet_pistol_tracer01_blue_crit"!
Attempted to precache unknown particle system "muzzle_scattergun"!
Attempted to precache unknown particle system "bullet_scattergun_tracer01_red"!


Load game mode and fire a weapon and get a room full of red X's....
Showing 1-9 of 9 comments
< >
Heinrick Feb 7 @ 7:40pm 
I used to get that EVERY TIME I installed SFM. I figured out what was wrong, though. I was mounting assets in 'usermod', and they [particles] were overwriting each other. I never fixed this until I removed and reinstalled it. If you are putting files in there, you should make another 'game' folder, and add it to the search paths in the usermod folder's gameinfo.txt.
Last edited by Heinrick; Feb 7 @ 7:41pm
Thanks Heinrick, but I don't think that is my problem, but I think I will use the suggestion and throw my particle files into a folder and give it a higher priority in the gameinfo.txt file, just to see if it fixes the problem. With all the fiddling I do to try and figure out the problems I answer here it is a possibility that I've screwed up the processing order up and the game mode just isn't finding the particles.
Nope, didn't work. Ported all the particles to usermod\particles and still the samething; a room full of beautiful red X's... Wish I could figure this out... I'm trying to create some ragdoll animations.
Hmmm, I wonder if my problem is that I extracted the particles from the TF2 game VPK into my SFM\game\TF particles folder and that the particles from the VPK aren't what SFM is looking for. That the particle system is too advanced for SFM. I guess it's timeto do a verification of the local application to test this theory out. Will post back when I have done that. Dag it... Another 8 gig download if SFM and Steam thinks my system is corrupt.
Pte Jack is away for a MONTH Feb 11 @ 11:40pm 
Well, it is what I thought... Went from a room full of beautiful red X's to proper particles after removing the Usermod folder and validating again. Renamed the new updated usemod folder and threw my old usermod back into the games folder and plumes of red X's again.

So, Something between the 2 usermod folders is different and causing the problem. Back in a bit....
raptornx01 Feb 12 @ 6:33am 
when you grabbed the TF2 stuff from the vpks did you merge it with the tf2 folder, or put it in the usermod folder?

if you validate only and leave your current usermod alone does it fix it?
Don't know Raptorn, I pulled the usermod folder out before the verification. I have too much stuff in there to mess that up.
Katana Feb 12 @ 3:47pm 
I'm not sure if I follow; why would you be grabbing all of TF2's contents from the VPK? Source Filmmaker pretty much comes with a near-complete installation of Team Fortress 2 in the tf directory.
I would guess that part of the reason might be if Team Fortress 2's engine version, and the particle system, makes slight upgrades and adjustments that don't carry to SFM's engine straight away. That seems unlikely though.
the newer stuff takes a while to port into SFM (ie the 2013 halloween and smissmas stuff or the newest Community based stuff), I use the VPKs to grab that instead of waiting around for an update.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Feb 7 @ 6:54pm
Posts: 9