Source Filmmaker

Source Filmmaker

Zappy Jun 16, 2014 @ 3:18am
Keyvalue string space? What's that?
No, seriously, what is "keyvalue string space"? I don't know, but apparently Source FilmMaker just crashed with the error box "Out of keyvalue string space".
Sure, it's the first time that has happened for me in my almost 3000 hours of use, but I'm curious as to what it actually is.
< >
Showing 1-15 of 19 comments
6000 ANGRY BEES Jun 16, 2014 @ 6:42am 
Okay, so you know when you create an animation set and the model browser comes up and creates a big list of your models? And when you add a sound and the same thing happens but for sounds? And so on for materials?

Those all use the same "list", for lack of a better word, that has a limited amount of slots. When SFM runs out of slots, it gives you the keyvalue string space error and crashes.

The best solution to this problem, sadly, is just to mount less models or sounds into SFM.
Zappy Jun 16, 2014 @ 7:00am 
Originally posted by 6000 ANGRY BEES:
The best solution to this problem, sadly, is just to mount less models or sounds into SFM.
Well, I think it happened after I added a sound, cut it at a spot, deleted the latter part of it, and moved the playhead a bit (with the right arrow key).
After the crash, I rebooted the FilmMaker, reopened the session, and did the same thing, but along with other things, and it didn't crash, though I didn't remove any things.
6000 ANGRY BEES Jun 16, 2014 @ 10:55pm 
Yeah, SFM keeps filling out the "list" even after you close the window. Hence your delayed crash.
Zappy Jun 16, 2014 @ 11:18pm 
Well it didn't crash the second time, though.
raptornx01 Jun 17, 2014 @ 1:09am 
I don't know about the sound folder, but i know the model veiwer, at least for me, stops loading if i select a model or close the window.

try starting a new session, open the model viewer, let it load everything. the open the sound list. see if it happens again.

If it does, best bet is to just comment out a folder in gameinfo that you don't use that often.

how many models do you have BTW?
Zappy Jun 17, 2014 @ 4:39am 
The sound list keeps loading when closed, the model browser doesn't.

And according to the fully loaded lists, I have 14830 models* and 42140 sounds** (both are currently fully loaded in the same session that crashed earlier, except I've expanded upon the session by now, and it doesn't crash).

* 558 in usermod, 555 in tf_movies, 5117 in tf_fix (basically extraction of the .vpk files), 0 in tf, 18 in left4dead2_movies, 159 in l4d2_fixes, 3229 in left4dead2, 779 in dod, 19 in n64, 2101 in portal2, 1984 in hl2, 311 in workshop, 0 in platform.

** 1029 in usermod, 90 in tf_movies, 11430 in tf_fix, 0 in tf, 17939 in left4dead2_movies, 0 in l4d2_fixes, 0 in left4dead2, 761 in dod, 0 in n64, 8520 in portal2, 2371 in hl2, 0 in workshop, 0 in platform.
R234 Jun 17, 2014 @ 3:51pm 
19968 models, 29445 sounds, 92 maps, 31684 materials. All lists fully loaded, no crash. Dunno what that keyspace stringymabob whateveritscalled limit is, but it's apparently higher than 81189. And that's if those lists are the only thing that count towards that limit...
raptornx01 Jun 17, 2014 @ 6:31pm 
if it doesn't crash, maybe it was just a specific glitch. keep going and see if it happens again.
Zappy Jun 17, 2014 @ 11:23pm 
Originally posted by raptornx01:
if it doesn't crash, maybe it was just a specific glitch. keep going and see if it happens again.
Will do. If it happens again, which I doubt, I will be sure to post here again.
Zappy Jun 24, 2014 @ 2:44am 
Okay, so it happened yesterday. I had no internet at that moment, so Source FilmMaker complained about workshop stuff (it didn't delete or add or edit any, but it still complained), and I did have 10 more .mp3 files in usermod than before. Anyway, I had the model list fully loaded, sound list fully loaded, did some stuff, and then it crashed with that error again. And just like before, it didn't crash again after rebooting.
raptornx01 Jun 24, 2014 @ 5:49am 
i suspect "did some stuff" could be the variable.

if you can, try retracing your steps and see if ti happens.

otherwise, maybe comment out some folders with models and sounds you don't really.
Zappy Jun 24, 2014 @ 5:50am 
"Some stuff": Adding sounds from the sound browser into the session to make a video, then move the sound clips around.
raptornx01 Jun 24, 2014 @ 5:54am 
how many sounds? and how many models do you have spawned?
Zappy Jun 24, 2014 @ 6:05am 
In that session I think I had about 20 models shattered over 4 shots spread across 7 seconds. Well when it crashed. And 1 or 2 sounds before it crashed. I don't remember, but it sure doesn't happen right now.
Flash Man Feb 22 @ 4:46pm 
It says I have no more keyvalue string space in TF2. Help plz? I restarted my COMP. and it still happens.
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: Jun 16, 2014 @ 3:18am
Posts: 19