SamSpielberg Jun 15 @ 8:50pm
See Through Props (Broken AO)
I have the sports car that comes with the SFM beta models, but the car itself doesn't support Ambient Occlusion and thus is all see-through-y, like so:
http://steamcommunity.com/sharedfiles/filedetails/?id=271516307&fileuploadsuccess=1
Any fix is greatly appreciated.
Showing 1-9 of 9 comments
< >
Sync. Jun 15 @ 9:10pm 
IIRC there is no way to fix this, unless someone knows how.
[G.o.D.] Strashniy Velikhan Jun 15 @ 10:02pm 
Like Sync. said, if anyone can fix it, then ask the person who can to help you. Or find something similar to that car. But if you want to stick to what you already have, as long as everything else works, it should be fine if it's see through. No one will really care. :/
raptornx01 Jun 15 @ 10:36pm 
try adding

"$alphatest" "0"

to the vmts (quotes and all)
SamSpielberg Jun 16 @ 8:31am 
Originally posted by G.o.D. Strashniy Velikan:
Like Sync. said, if anyone can fix it, then ask the person who can to help you. Or find something similar to that car. But if you want to stick to what you already have, as long as everything else works, it should be fine if it's see through. No one will really care. :/
I care. :)

Originally posted by raptornx01:
try adding

"$alphatest" "0"

to the vmts (quotes and all)
Ah! That's it. I remember the method involved adding something to the .vmts. Trying that now.
SamSpielberg Jun 16 @ 8:44am 
Alright. Got it fixed. In addition to your fix, raptornx, I also re-tried Patrick Jr.'s guide, which involved adding "$AmbientOcclusion" "0" to all the .vmt files and setting the "$alphatest" to "1" instead of "0". Thanks guys!
Sync. Jun 16 @ 1:08pm 
No, I don't think that's a fix. That just means you throw the AO away.
Can you screenshot on what happens when they are $alphatest is zero ?
raptornx01 Jun 16 @ 2:31pm 
they still have AO.
SamSpielberg Jun 16 @ 7:06pm 
Yes, it appears that I have just turned off the AO for the car. I don't really care though, so long as it's no longer transparent.
Sync, I turned the $alphatest to 0 on everything, leaving "ambientocclusion" set to 0. The car is still solid with AO turned on.
Last edited by SamSpielberg; Jun 16 @ 7:08pm
raptornx01 Jun 16 @ 8:32pm 
alphatest shouldn't disable AO. right click the viewport, go to render settings and select show ambient occlusion. the screen will go white except for shading.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Jun 15 @ 8:50pm
Posts: 9