Danomane Jun 9 @ 6:31pm
why do i have bad framerate in SFM
all my games have good fps its just SFM for some reason my framerate drops down by a lot
any solutions
Last edited by Danomane; Jun 9 @ 6:32pm
Showing 1-13 of 13 comments
< >
Pte Jack Jun 9 @ 8:43pm 
what are your computer specs and how is your connection to the Steam Servers that SFM is talking to?
Danomane Jun 9 @ 10:50pm 
these are my specs
Operating System: Windows 8.1 64-bit (6.3, Build 9600) (9600.winblue_gdr.140305-1710)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion TS 15 Notebook PC
BIOS: F.14
Processor: AMD A8-4555M APU with Radeon(tm) HD Graphics (4 CPUs), ~1.6GHz
Memory: 4096MB RAM
Available OS Memory: 3270MB RAM
Card name: AMD Radeon HD 7600G

i do not know the connection
Pte Jack Jun 9 @ 11:43pm 
Your Notebook... Should be good enough to give you a fairly good FPS. However, with all the load that is put onto a laptop, that could be one reason. What other programs do you have open in the background and eating memory... When the FPS drop, there is a memory counter in the bottom right hand corner of the SFM Screen, does it turn red?
Danomane Jun 10 @ 12:23am 
i do not run any programs in background other than sream and no it does not turn red
Pte Jack Jun 10 @ 9:41am 
So, that means it isn't a memory problem. I do know that SFM talks to Steam servers. I works fine on my laptop most of the time but when Steam is having issues, my FPS drops to almost nothing and SFM lags like crazy. Sometimes it take forever to scan through the 21,000 models I have loaded, other times only a couple of seconds (this not after initial start up either)

If you find lag so terrible, try to run it in offline mode, see if that clears anything up, also turning off lights, and I believe progressive refinement may help. Another thing you might try is to click the visiblilty button beside models you aren't working with, this should turn them off and that might help (haven't tried it), just remember to turn them bak on before rendering.
Danomane Jun 10 @ 11:14am 
ok ill try that and just to let you know it lags a lot whenever it switches cameras to different scenes and whenever a scene has shooting of any kind specifically the soldier shooting rockets.
Pte Jack Jun 10 @ 12:00pm 
Wait, are you talking in gameplay record mode or animating manually...
Danomane Jun 10 @ 12:45pm 
the only time it lags is whenever i watch what i made thats what i meant to say
Pte Jack Jun 10 @ 1:14pm 
As in pressin play in SFM or the actual render?
Danomane Jun 10 @ 3:21pm 
pressing play
Pte Jack Jun 10 @ 5:44pm 
OOOOHHHHH.... That's normal, it depends on what you have in the scene, the amout of animation and how cpu intensve it is... The computer is trying to render everything that's happening. It won't affect the movie if you render it.
Danomane Jun 10 @ 6:00pm 
how do you render lol
Pte Jack Jun 10 @ 6:13pm 
File export movie
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Jun 9 @ 6:31pm
Posts: 13