《Λϟ》|-|Blaze|-| Aug 10 @ 5:56am
Rendering time
I spent like 2 hours making a 2 minute movie , and when i tried to render it (on 480p) i had to wait 12 HOURS!
Is there something i can disable (Without making my movie look ♥♥♥♥ty) to wait atleast 5 hours?

Yes i know , my potato is pretty bad . But there's nothing i can do atm.
Showing 1-15 of 30 comments
< >
Vintage Aug 10 @ 5:59am 
You can try lowering the exported framerate from 400000 frames per second to 30, and set depth of field and motion blur to 8 samples instead of 1024.

Also note particles and lights can severely impact rendering time if used without care.

Disabling ambient occlusion is also a possibility, but it will impact quality a bit, depending on models used.
《Λϟ》|-|Blaze|-| Aug 10 @ 6:02am 
Originally posted by Vintage:
You can try lowering the exported framerate from 400000 frames per second to 30, and set depth of field and motion blur to 8 samples instead of 1024.

Also note particles and lights can severely impact rendering time if used without care.

Disabling ambient occlusion is also a possibility, but it will impact quality a bit, depending on models used.


Yeah in my film i have quite alot of particles going on (mostly at the beginning)
Like rocket smoke , rocket explosions , demoman bombs and many other.

Thank you though.
Vintage Aug 10 @ 6:11am 
The closer particles are to the camera, the more they will slow down stuff. Why? No idea.
《Λϟ》|-|Blaze|-| Aug 10 @ 6:16am 
Originally posted by Vintage:
The closer particles are to the camera, the more they will slow down stuff. Why? No idea.
Lol I don't know either.

But where do i change these the exported framerate?
Doesn't seem to be in the rendering menu (if i'm not missing it)

Vintage Aug 10 @ 6:24am 
When using File > Export > Movie, one of the tabs contains "Override framerate". Turn that on.
Note that if your framerate is already 30, it will take just as long to render something as without the override.
If your framerate is already below 30, it will make the rendering take more time if you use the override.
However, one should never go past 30 when rendering, as YouTube caps videos to 30 frames per second.

Also note that after rendering if using the override, the session will be changed to use the framerate you chose when rendering, unless you close Source FilmMaker and reboot it before saving.
《Λϟ》|-|Blaze|-| Aug 10 @ 6:26am 
Originally posted by Vintage:
When using File > Export > Movie, one of the tabs contains "Override framerate". Turn that on.
Note that if your framerate is already 30, it will take just as long to render something as without the override.
If your framerate is already below 30, it will make the rendering take more time if you use the override.
However, one should never go past 30 when rendering, as YouTube caps videos to 30 frames per second.

Also note that after rendering if using the override, the session will be changed to use the framerate you chose when rendering, unless you close Source FilmMaker and reboot it before saving.

Oh ok it was on 24 frames , changed it to 30 , thanks!
Vintage Aug 10 @ 6:30am 
As I stated, that will just make it take 25% longer to render.

(24/30=1.25*100=125% of the previous rendering time.
As in, previous framerate divided by new framerate, then multiplied by 100 gives the percentage of time it will take to render, 100% being the same as before changing the framerate.)
《Λϟ》|-|Blaze|-| Aug 10 @ 7:00am 
Originally posted by Vintage:
As I stated, that will just make it take 25% longer to render.

(24/30=1.25*100=125% of the previous rendering time.
As in, previous framerate divided by new framerate, then multiplied by 100 gives the percentage of time it will take to render, 100% being the same as before changing the framerate.)

I think the biggest problem was the easiest problem to notice . I recorded like 10 takes , and also had 10 cameras moving everywhere , almost everytime , now they're deleted . Let's see how it works.
《Λϟ》|-|Blaze|-| Aug 10 @ 7:00am 
Wow! 5.3 hours , that's so much better!
Also thanks for the help!
《Λϟ》|-|Blaze|-| Aug 10 @ 7:05am 
8.3 ...
Vintage Aug 10 @ 7:22am 
Honestly, I think you need a new/better computer if you want to keep using Source FilmMaker.
《Λϟ》|-|Blaze|-| Aug 10 @ 7:35am 
Originally posted by Vintage:
Honestly, I think you need a new/better computer if you want to keep using Source FilmMaker.

Yeah , as i said in the post , my potato's really bad.
Vintage Aug 10 @ 7:36am 
And what does your potato have to do with anything?
《Λϟ》|-|Blaze|-| Aug 10 @ 7:39am 
Originally posted by Vintage:
And what does your potato have to do with anything?

By potato i mean my pc xD

And does blur make sfm videos ALOT more time to render?

Vintage Aug 10 @ 7:48am 
If you turn on subpixel anti-aliasing or whatever, it will take at least 4 samples per frame. If you turn on depth of field, it will usually take 8 samples per frame. Leaving anti-aliasing, depth of field and motion blur on at the same time takes just as long to render as if only depth of field or motion blur is on. They will highly increase ambient occlusion quality.

But yes, anti-aliasing + depth of field + motion blur will make videos take 800% time to render compared to all those being off. Anti-aliasing alone will make videos take 400% time to render.

However, due to how bad ambient occlusion looks without those, it's advised to turn ambient occlusion off before/instead of disabling depth of field, motion blur and anti-aliasing, as that will also decrease the rendering time by quite a bit.

Looking at it taking so long for you to render those 2 minutes, though, you may want to disable ambient occlusion as well as depth of field, motion blur and anti-alias.
Showing 1-15 of 30 comments
< >
Per page: 15 30 50
Date Posted: Aug 10 @ 5:56am
Posts: 30