YunChang 云长 Aug 2 @ 6:32am
SFM Dota Map
Hey guys,

Im sure many of you have passed by this.
The Dota map uses BSP 23, SFM uses max BSP 21.
So I downloaded this cleaned up version of the dota map: http://facepunch.com/showthread.php?t=1238315
But when I load this map, SFM just crashes.

I really dont know whats wrong..
Any help?
Showing 1-15 of 15 comments
< >
Luke Allstar Aug 2 @ 6:38am 
Try this one: http://facepunch.com/showthread.php?t=1300754
Also works with CustomHero shader for the most part

or search the SFM workshop for the dota2 map, that seems also to be working
YunChang 云长 Aug 2 @ 7:01am 
Thank you for the suggestion bro.

I was able to load the map after realizing I had overloaded the rendering.
So I right clicked the view and removed as much as possible of what should be rendered.
The map finally loaded!

Thank you so much~
YunChang 云长 Aug 2 @ 7:19am 
Tho, after it loaded, it looks like this now: http://gyazo.com/0b95253b3f7dc20b047f1c4132d52ed8
Any ideas why?
Luke Allstar Aug 2 @ 7:52am 
You probably disabled drawing of World Brush models
Right Click on Viewport > Draw Game Entities > World Brush Models
YunChang 云长 Aug 2 @ 8:03am 
When I do that it crashes :c.....
Luke Allstar Aug 2 @ 8:17am 
strange ..
have you unpacked all props from your dota2 vpk and put them on the SFM location?

You can also try using the Map props from (search for Release1) here http://facepunch.com/showthread.php?t=1300754
These are updated props, maybe they work a bit better

Haven't had that propblem myself so no idea what might be wrong :/
YunChang 云长 Aug 2 @ 8:36am 
Yeah I follow cyborgmatts guide properly, The models (such as invoker and such) work perfectly fine, I did this video 2 days ago :http://www.youtube.com/watch?v=MNTHIoqg5TQ
The only prob is the bloody map :s

I'll try those props now, are they the ones ur using?
Luke Allstar Aug 2 @ 8:41am 
Cyborgmat's tutorial is really old and i think some parts are outdated
I'm using the map and props from that site. I also use some of the HD models that BlueFlytrap uploaded (also on the same page)

Maybe you have to undo parts of Cyborgmats tutorial (changing CustomHero to something else in the .vmt files)
Maybe you can find out if there is an error log / crash dump so we know if there is just a file missing or something like that
YunChang 云长 Aug 2 @ 8:42am 
ooh I see, then Ill try to just transfer the files without changing the VertexLit thingy

To create an error log txt u need to write a certain command into the console, I used it 2 days ago but I cant find it now haha, it was something like /con_logfile error.txt I guess?
YunChang 云长 Aug 2 @ 9:58am 
No use :/
Activating World Brush Models still crashes the whole thing
Luke Allstar Aug 2 @ 10:40am 
Sorry but I'm kinda out of ideas now. Maybe you can get the errorlog so we can identify the problems further ..

Btw. which map are you using now? The one from BlueFlytrap or from The Kins on Facepunch or the one from the workshop?
Luke Allstar Aug 2 @ 10:48am 
Also i forogot here is another map .. maybe this works better for you http://facepunch.com/showthread.php?t=1303509
YunChang 云长 Aug 2 @ 10:57am 
Tried on both, same results

I have a log file of the map loading here: http://m.uploadedit.com/b038/14070022058.txt

I tried that map too, same error ;c

Luke Allstar Aug 2 @ 11:32am 
nothing that really stands out as far as i can tell :/
maybe try extracting everything again, maybe you missed something or something didn't properly extract or so .. i don't know
YunChang 云长 Aug 2 @ 11:50am 
sigh u.u..
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Aug 2 @ 6:32am
Posts: 15