Mass Effect > General Discussions > Topic Details
LokiSince91 Nov 23, 2012 @ 12:17am
Mass Effect wont launch
Having some problems launching this game sucks cuz its the only game i havent played in the trio saw it on sale and jumped on it.. WELL at first launch i got an error where it just flickerd the screen and said launch error and had to close.. I did some research and i tried running as admin on xp sp3 and 2 and now i just get a black screen til i press ENTER and it just closes the screen. THIS SUCKS im new to steam and i feel robbed.. my computer is more than capable of running ANY HELP WILL BE GREAT
Showing 1-14 of 14 comments
< >
ONe_mOMENT Nov 23, 2012 @ 1:17am 
You need to run Steam as admin not Mass effect itself.

Don't know why it has this problem with steam. Origin copy runs flawlessly without needing to run anything as admin.
LokiSince91 Nov 23, 2012 @ 11:27am 
ive tried that as well and i still get the same error message =[
cointerm Nov 23, 2012 @ 8:06pm 
Are you using Windows 7? Since you have Mass Effect 2, try this:

http://www.youtube.com/watch?v=Q5pvlyCgvy0

LokiSince91 Nov 23, 2012 @ 8:17pm 
no i dont have mass effect 2 i have it but on ps3 not pc
༼ つ ◔_◔༽つ P♉ngo Nov 23, 2012 @ 8:33pm 
Just beat ME3 and wanted to go back to play a Fem Shep from the start and had a crash issue as well. What fixed the insta crashing on Win8 was right clicking on Masseffect.exe located in C:\Program Files (x86)\Steam\steamapps\common\Mass Effect\Binaries and checking off Run as administrator.

I also did the same for Masseffectconfig.exe.

Hope that hopes.

(your might be located at C:\Program Files\ without x86 in it depending on version of windows)
Last edited by ༼ つ ◔_◔༽つ P♉ngo; Nov 23, 2012 @ 8:34pm
XeniX Nov 25, 2012 @ 4:57am 
Set MassEffect.exe, and MassEffectConfig.exe in "...\Steam\steamapps\common\mass effect\Binaries" to run as administrator.
Try loading the 1.02 patch. Had same issues with Win7 64 bit. Would start and just stop with no warning.
Here's a link: Mass Effect 1.02 Patch (http://www.shacknews.com/file/14289/mass-effect-102-patch)
I do run the Steam version and found manually installing patch made it work again.
Last edited by XeniX; Nov 25, 2012 @ 5:20am
LokiSince91 Nov 25, 2012 @ 6:47pm 
ok i tried and now im getting an error saying im missing a file which is the one i changed =[ idk what to do but thanks anyways guys appreciatte the help
PiNoYeBoY85 Nov 25, 2012 @ 8:14pm 
How do you check to see if your ME1 on Steam is running the 1.02 patch? I just dl ME1 today.
LokiSince91 Nov 26, 2012 @ 1:01pm 
i downloaded the [atch from the website and when i tried installing it it said it was already running the latest patch so im assuming its the 1.02 patch
AnDy Dec 22, 2012 @ 11:22am 
I patched an am DL the DLC . BUT It wont launch... says missing Launcher.xml... repaired 5 times. I donno what to do next?
AnDy Dec 22, 2012 @ 11:24am 
Had to Put the Patch in the binaries file to get it to work.
AnDy Dec 22, 2012 @ 1:52pm 
run as Admin works. Steam.exe that is
florinandrei Dec 23, 2012 @ 1:09am 
I launched Steam as admin, and that fixed the crash. After that, I launched Steam again, as non-admin, and now the game is working fine again. Looks like I only had to run Steam as admin once.
bkenny583 Dec 24, 2012 @ 9:37pm 
So launching as admin didn't work. I went into binaries and ran the runme file and now it seems to be working fine so far.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Nov 23, 2012 @ 12:17am
Posts: 14