Mass Effect > General Discussions > Topic Details
Peitz Dec 25, 2012 @ 1:26pm
Not launching! any ideas
Hey, i just bought the ME bundle today and experienced a whole lot of christmas cheer while not being able to play it. Its just not launchin. No error msg occurs, no difference between running as admin or not...using the actual game/launcher exe wont help either! Its Windows 7....dont know what to do!
Showing 1-15 of 70 comments
< >
just_anotheroutlaw Dec 25, 2012 @ 1:27pm 
I'm having this same problem. :(
Peitz Dec 25, 2012 @ 1:29pm 
welcome to the club=)
just_anotheroutlaw Dec 25, 2012 @ 1:30pm 
do we get jackets? :D
⌂m Dec 25, 2012 @ 1:30pm 
eeyup
david_moussa Dec 25, 2012 @ 1:34pm 
I've search solutions on the web for the last week ... didn't find anything useful (so much joy)
just_anotheroutlaw Dec 25, 2012 @ 1:37pm 
this helped me, maybe it will help you?

Posted by Pixel_Pro:
I did not have this problem with ME on Steam when I had old Windows, but now on Windows 7 64bit I had same prob and my solution was to make game not only always run as admin, as said
Originally posted by Maimsteen:

Go to your Mass Effect folder, C:\...\Steam\steamapps\common\Mass Effect\Binaries. Right click MassEffect.exe and click the compatibility tab, then click the box beside "Run this program as an administrator"


but also set in compatibility properties: Run this program in compatiblity mode for Windows XP SP3.

It seems that in general many games have probs with 64bit Windows and many especially with Win7 64bit.



thank this steam user for help, also go into mass effect config options to tweak etc ( not needed 2 launch)
Peitz Dec 25, 2012 @ 2:42pm 
The compatibility mode solved my problem....its running i tell ya!!!^^.....just right click the .exe in your folder and start compatibility........
Rhenthyl Dec 25, 2012 @ 5:59pm 
Also, if you have a multi monitor set up you have to physicaly disconect/disable all but your primary otherwise the game just refuses to run
Tamojin Dec 25, 2012 @ 7:02pm 
Hey all. Thanks for all the effort in finding a solution to this. Hopefully you might have some ideas for me too. The compatibility mode isn't working for me at all, nor is running Steam as an admin. I'm getting a completely black screen and when I tab out of the frozen program, I get this message:

General protection fault!
History:GMatrix2D:: Swap() Address = 0x10bb5c66 (filename not found) [in C:\Program Files (x86)\Steam\Steamapps\Common\Mass Effect\Binaries\MassEffect.exe]
Address = 0x154d3ee4 (filename not found)

Any ideas, thoughts, or possible solutions?
zl-_-ly Dec 25, 2012 @ 7:04pm 
Thanks for the help!
Masked Antihero Dec 26, 2012 @ 11:58am 
Damn it also doenst work at me, also tried the admin thing and compatiblity...
[J5]MrGoopy Dec 26, 2012 @ 12:27pm 
Same Problem here - I've been waiting for Mass Effect to go on the Steam sale - I get it and cannot load - locks up after load screen. I've tried to run as admin and compatibility also. Running 64bit Vista
rawrberrie Dec 26, 2012 @ 1:16pm 
Was having same problem on Vista. Ran as admin in combatibility mode with XP SP2 and everything works now. Thanks for the help!
Owen Dec 26, 2012 @ 1:42pm 
Thanks. Changing the compatibility properties for the executable to XP SP3 worked fine for me.
Unames Dec 26, 2012 @ 1:47pm 
I tried the settings recommended for 64 bit windows, but the application crashes with a steam error message saying 'Failed to start game (app already running)'
Showing 1-15 of 70 comments
< >
Per page: 15 30 50
Date Posted: Dec 25, 2012 @ 1:26pm
Posts: 70